Offline setup issue: Linux 1.1.2

Asked by Brad Erwin on 2018-06-14

I've successfully installed 1.1.2 on my Windows machine, however, I would like to get it to work on Linux as well. The trouble is that the Linux machines are managed by the corporate IT organization and typically do not have access outside the firewall. There is a proxy, but it is not configured by default.

Consequently, the 1.1.2 setup fails when trying to download maven-metadata.xml.

There doesn't seem to be any way to download these files for true offline setup. I downloaded the xml to the Downloads directory to no effect.

Directory tree:
|-- ./Downloads
| |-- ./Downloads/jython-standalone-2.7.1.jar
| |-- ./Downloads/maven-metadata.xml
| |-- ./Downloads/sikulixlibslux-1.1.1.jar
| |-- ./Downloads/sikulixsetupAPI-1.1.2-20180308.083909-100.jar
| `-- ./Downloads/sikulixsetupIDE-1.1.2-20180308.083933-100.jar
`-- ./sikulixsetup-1.1.2.jar

Error message:

[debug] FileManager: download to string from:
https://oss.sonatype.org/content/groups/public/com/sikulix/sikulixsetupIDE/1.1.2-SNAPSHOT/maven-metadata.xml,

[error] FileManager: problems while downloading
Connection timed out (Connection timed out)
[error] RunSetup: Maven download: could not get timestamp nor buildnumber for sikulixsetupIDE#forsetup from:
https://oss.sonatype.org/content/groups/public/com/sikulix/sikulixsetupIDE/1.1.2-SNAPSHOT/maven-metadata.xml
with content:

[debug] FileManager: download to string from:
https://oss.sonatype.org/content/groups/public/com/sikulix/sikulixsetupAPI/1.1.2-SNAPSHOT/maven-metadata.xml,

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2018-06-14
Last reply:
2018-06-16
RaiMan (raimund-hocke) said : #1

Offline setup does not work with version 1.1.2

Use the nightly build 1.1.3:
https://raiman.github.io/SikuliX1/nightly.html

Can you help with this problem?

Provide an answer of your own, or ask Brad Erwin for more information if necessary.

To post a message you must log in.