Hang Sikuli on minimizing

Asked by Alex Lunyov on 2018-05-18

I use Sikuli 1.1.2 (last build) on my Win 7-64 with last Java 8-171.
Strange to see it hangs (20-30% CPU) even on empty script.

My test:
1. I launched Sikuli 1.1.2. There was one empty tab, nothing else.
2. I minimized the window to the tray.
3. Left clicked the app to bring it back.
4. Minimized again.

I noticed that CPU became 20-30% busy (forever, minutes).

And some more:

5. Ran simple "i = 0" – CPU 0%
6. Minimized Sikuli to the tray. CPU became 30% again.

It seems it could be a Java problem, because I tested a number of previous nightly versions 1.1.0 and 1.1.1 and encountered the same issue.

P.S. The same issue while maximizing and even moving the IDE window. The same on my home Win 10 with the latest Java and Sikuli 1.1.2.

Need help :)

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Alex Lunyov
Solved:
2018-05-18
Last query:
2018-05-18
Last reply:
2018-05-18
RaiMan (raimund-hocke) said : #1

I cannot help you, but is it really a problem?

Try to go back to 1.8-16x or try Java 9 or 10 (with SikuliX 1.1.3)

Alex Lunyov (lunyov-av) said : #2

Thanks a lot! Now it works fine, on Java 10 + SikuliX 1.1.3.