MoveMouseDelay=0 cause error

Asked by aobahou on 2018-05-10

Hi,

I am using sikulix in my project and I want speed up to save time. The code can work with Setting.MoveMouseDelay=0.5.

When I try to set the Setting.MoveMouseDelay to 0, sikulix just can't click in the right position.

And the log shows:
[error] RobotDesktop: checkMousePosition: should be ***
but after move is ***
Possible cause in case you did not touch the mouse while script was running:
 Mouse actions are blocked generally or by the frontmost application.
You might try to run the SikuliX stuff as admin.

But I check the document, it says:

Settings.MoveMouseDelay
Control the time taken for mouse movement to a target location by setting this value to a decimal value (default 0.5). The unit is seconds. Setting it to 0 will switch off any animation (the mouse will “jump” to the target location).

I am using java_8_171 64 bit version, win10, sikulix1.1.1.

Looking forward to any reply, thanks for the great project and help.

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Roman Podolyan
Solved:
2018-05-14
Last query:
2018-05-14
Last reply:
2018-05-10

Use Settings.MoveMouseDelay = 0.1

(Picked that from other topic, https://answers.launchpad.net/sikuli/+question/295187 )

aobahou (aobahou) said : #2

Thanks for the kind help, but a 100ms delay is not acceptable for me.
I solved this problem by the java robot framework, just like robot,mouseMove(x, y) and robot.keyDown() and robot.keyUp().
And the delay is about 15ms.

aobahou (aobahou) said : #3

Thanks Roman Podolyan, that solved my question.