InitNativeSupport error when trying to open SikuliX.app

Asked by Gayathri Venkat on 2018-05-03

Hi,
My Mac is running JAVA build 1.8.0_171-b11
I downloaded and installed sikulixsetup-1.1.2.jar.
Setup.log has ' RunSetup: ... SikuliX Setup seems to have ended successfully ;-)'

When trying to open the SikuliX.app, I get a popup window with
IDE has problems. initNativeSupport: Mac: error: com.apple.eawt.AboutHandler.

Would appreciate any help with this.

Thank you!!

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2018-05-03
Last reply:
2018-05-05
RaiMan (raimund-hocke) said : #1

Looks like you are actually running Java9 in that moment.

Try with version 1.1.3 nightly.

Gayathri Venkat (gv66) said : #2

Thank you RaiMan for your response.

My Mac has jdk-10.0.1.jdk and jdk1.8.0_171.jdk with JAVA_HOME set to jdk1.8.0_171.jdk.
I'm not sure I'm running JAVA 9.

Clicking on Application -> SikuliX.app give the error mentioned above.

But when I try 'open /Application/SikuliX.app' opens the application.
I think this is a workaround for opening the app.

RaiMan (raimund-hocke) said : #3

So you are even running Java 10 by default.

From the normal GUI on a Mac always the newest version of Java is taken (in your case Java 10). This does not work with SikuliX 1.1.2.

When you run from a Terminal having JAVA_HOME set to Java 8, it takes Java 8 when running anything that needs Java.
So if you run anything with respect to SikuliX 1.1.2 from a Terminal, you will not have problems.

When using SikuliX 1.1.3, then you can run with any Java beyond 8 without abny restrictions.

Can you help with this problem?

Provide an answer of your own, or ask Gayathri Venkat for more information if necessary.

To post a message you must log in.