Execute sikulix script not working

Asked by Edson Henrique Arantes on 2018-04-19

When I named my sukilix scripts like My_sikuli.sikuli; mysikuli2.sikuli or my.script.sikuli... when I use number, underline, trace, dots in the name of the script, they don't run via terminal, the message is show ->

FileManager: Script project C:\Users\Edson\Desktop\teste-1.sikuli has no script file teste-.xxx

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2018-04-25
Last query:
2018-04-25
Last reply:
2018-04-21
RaiMan (raimund-hocke) said : #1

What version of SikuliX?

How do you run the scripts?

Supposing you are using Python scripting:
Does the script teste-1.sikuli contain a file teste-1.py?

Hello, thanks for the aswer!
I'm using sikulix version 1.1.2 and yes, the files are like this

teste_1.sikuli -> teste_1.py and images

I'm running like this, enter the cmd as admin and type

PATH-TO-Sikuli -R PATH-TO-teste_2.sikuli

Best RaiMan (raimund-hocke) said : #3

ok, I have to check.

The only thing I can say already now: additional dots besides the .py don't work and hence are forbidden.

RaiMan (raimund-hocke) said : #4

checked with numbers and underscore: works

to run the scripts I used:
<path-to>\runsikulix.cmd -r testName_1

Thanks RaiMan, that solved my question.

I rename the folder but didn't rename the file insides it, sorry and thanks!