Sikuli doesn't work on MacOS 10.12.6 for Sikulix 1.1.1 with Maven download

Asked by Ke Chen on 2018-04-12

Sikuli doesn't work on MacOS 10.12.6 for Sikulix 1.1.1 with Maven download

I have repeated tryings, and get the best software guy here tried with me also:

the original problem is Sikuli doesn't find the image pop up from a flash Box, but eventually I have found Sikulix 1.1.1 doesn't work for anything on the screen. anything is not working, And I can't change the version from maven pom.xml file, if I have changed, it give me compile error, please check below, we really need to solve this issue now, here is my email, <email address hidden>, can you please send me your link, so we can share the screen to troubleshoot the problem, we have repeated trials already, thanks.

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 3.447 s
[INFO] Finished at: 2018-04-12T15:14:44-07:00
[INFO] Final Memory: 13M/309M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project BvClientTest: Could not resolve dependencies for project BvClientTest:BvClientTest:jar:0.0.1-SNAPSHOT: Failed to collect dependencies at org.sikuli:sikuli-core:jar:1.1.0: Failed to read artifact descriptor for org.sikuli:sikuli-core:jar:1.1.0: Could not transfer artifact org.sikuli:sikuli-core:pom:1.1.0 from/to sonatype-ossrh (https://oss.sonatype.org/content/repositories/snapshots/): US01CBCSG02.org.nasdaqomx.com: nodename nor servname provided, or not known: Unknown host US01CBCSG02.org.nasdaqomx.com: nodename nor servname provided, or not known -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project BvClientTest: Could not resolve dependencies for project BvClientTest:BvClientTest:jar:0.0.1-SNAPSHOT: Failed to collect dependencies at org.sikuli:sikuli-core:jar:1.1.0

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
21 hours ago
Last reply:
12 hours ago
RaiMan (raimund-hocke) said : #1

it is complaining about
org.sikuli:sikuli-core:jar:1.1.0

... but this has nothing to do with SikuliX.

this is what is available:
http://search.maven.org/#search%7Cga%7C1%7Ccom.sikulix

Ke Chen (kurtxchen) said : #2

I have installed sikulixapi-1.1.0 version sucessfully, but the image finding is still not working, I don't know why?

Is any way you can help me directly? here is my phone number: 650-495-5685. perhaps we can share the screen
to debugging. I am pretty sure somewhere, there are something worth you to troubleshoot, maybe something
you never thought about it.

BTW: 1.1.0 version doesn't have sikulix1tigervnc directory?

In my situation, everything is correct, but sikuli just can not find the image which is existed on the screeen.

Thanks
-Kurt.

us10mac00082:sikulix keeche$ ls -lR
total 0
drwxr-xr-x 2 keeche ORG\Domain Users 68 Apr 15 23:05 sikulix1tigervnc
drwxr-xr-x 3 keeche ORG\Domain Users 102 Apr 17 14:27 sikulixapi
drwxr-xr-x 3 keeche ORG\Domain Users 102 Apr 17 14:27 sikulixlibsmac

./sikulix1tigervnc:

./sikulixapi:
total 0
drwxr-xr-x 9 keeche ORG\Domain Users 306 Apr 17 14:27 1.1.0

./sikulixapi/1.1.0:
total 2272
-rw-r--r-- 1 keeche ORG\Domain Users 200 Apr 17 14:27 _remote.repositories
-rw-r--r-- 1 keeche ORG\Domain Users 1133330 Apr 17 14:27 sikulixapi-1.1.0.jar
-rw-r--r-- 1 keeche ORG\Domain Users 354 Apr 17 14:27 sikulixapi-1.1.0.jar.lastUpdated
-rw-r--r-- 1 keeche ORG\Domain Users 40 Apr 17 14:27 sikulixapi-1.1.0.jar.sha1
-rw-r--r-- 1 keeche ORG\Domain Users 5465 Apr 17 14:27 sikulixapi-1.1.0.pom
-rw-r--r-- 1 keeche ORG\Domain Users 354 Apr 17 14:27 sikulixapi-1.1.0.pom.lastUpdated
-rw-r--r-- 1 keeche ORG\Domain Users 40 Apr 17 14:27 sikulixapi-1.1.0.pom.sha1

./sikulixlibsmac:
total 0
drwxr-xr-x 9 keeche ORG\Domain Users 306 Apr 17 14:27 1.1.0

./sikulixlibsmac/1.1.0:
total 9760
-rw-r--r-- 1 keeche ORG\Domain Users 208 Apr 17 14:27 _remote.repositories
-rw-r--r-- 1 keeche ORG\Domain Users 4969174 Apr 17 14:27 sikulixlibsmac-1.1.0.jar
-rw-r--r-- 1 keeche ORG\Domain Users 354 Apr 17 14:27 sikulixlibsmac-1.1.0.jar.lastUpdated
-rw-r--r-- 1 keeche ORG\Domain Users 40 Apr 17 14:27 sikulixlibsmac-1.1.0.jar.sha1
-rw-r--r-- 1 keeche ORG\Domain Users 2705 Apr 17 14:27 sikulixlibsmac-1.1.0.pom
-rw-r--r-- 1 keeche ORG\Domain Users 354 Apr 17 14:27 sikulixlibsmac-1.1.0.pom.lastUpdated
-rw-r--r-- 1 keeche ORG\Domain Users 40 Apr 17 14:27 sikulixlibsmac-1.1.0.pom.sha1

RaiMan (raimund-hocke) said : #3

use version 1.1.2 or even 1.1.3 nightly

Ke Chen (kurtxchen) said : #4

Hi RaiMan,

You want to check, I have been used sikulix 1.1.1 and 1.1.0 and 1.1.2 version, none of them are working, I doubt sikuli is working
for MacOS 10.12.6 and Chrome 66.0 combination. I think it is really a problem for us right now.

Thanks.
-Kurt.

RaiMan (raimund-hocke) said : #5

--- Chrome 66.0 is not relevant for SikuliX

--- 1.1.1 surely works, is on MavenCentral, 1.1.2 and 1.1.3 work too, but are only avalable as SNAPSHOT from OSSRH

please check the dependency section from your project pom (the error you have is about org.sikuli:sikuli-core:jar:1.1.0 and this is not SikuliX)

You might paste the section here.

Can you help with this problem?

Provide an answer of your own, or ask Ke Chen for more information if necessary.

To post a message you must log in.