Notepad++ settings not compatible with Sikuli

Asked by arminius on 2018-03-22

I copy some code over to notepad++ because I find it has alot more useful features like find and replace.

I tab multiple lines then copy and paste the code back to Sikuli IDE, it won't save until I retab everything even though they are visually identical.

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2018-03-22
Last reply:
2018-03-22
RaiMan (raimund-hocke) said : #1

Why such complicated?

With a new script start in the IDE and save it once with a name.
Then close it in the IDE (no need to stop the IDE).
In notepad++ go to the folder younameit.sikuli and edit the file younameit.py. when ready, just save it.
Go back to the IDE and reopen your script.

Now you may even edit the script in the IDE (e.g. add images) and save it.
Even if you have the script still open in np++, it should tell you that the script was changed outside and ask for reload.

If you do not need the features of the IDE, you might run the script from command line (as far as I know, you might even do that from within np++ with an appropriate config).

RaiMan (raimund-hocke) said : #2

... and to answer your question:
You should take care, that you have the tab settings the same for .py files in np++ and the IDE (-> Preferences).
recommended: a tab is replaced by 2 blanks

Can you help with this problem?

Provide an answer of your own, or ask arminius for more information if necessary.

To post a message you must log in.