(Linux) Don't open the report after finishing tests

Asked by zingmars on 2018-03-14

I am looking into setting up a VM and making automated tests on it using Sikuli (the latest available). Now everything seems to be working fine, however even when sikuli is launched from a command line it will open the web browser with the report (which is uploaded as an artifact to the CI server). Now this isn't really that big of a problem as I can just kill the browser after running the tests, but it would be much cleaner if the browser never opened in the first place.
So the question is - is there a way to tell Sikuli NOT to open the report file after running the test?
Also, where are IDE settings stored? the docs say '~/.java/.userPrefs/org/sikuli/prefs.xml' but that file doesn't contain anything except for xml headers and doctype.

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2018-04-05
Last query:
2018-04-05
Last reply:
2018-03-15
RaiMan (raimund-hocke) said : #1

--- however even when sikuli is launched from a command line it will open the web browser with the report
I am not aware of any SikuliX feature, that opens a browser to show stuff.

So please be more precise what YOU have in your script.

zingmars (zingmars) said : #2

Welp, upon closer inspection it seems it's being autogenerated by robot framework (which is odd, because nowhere in my script does it tell robot fw to actually do this). What threw me off was the comment at the top of the opened report - https://i.imgur.com/l2fHxgT.png. It's basically a report that looks like this - http://robotframework.org/QuickStartGuide/report.html. For reference, this is the test script I was given - https://ayy.lv/u51kqhef.zip.

In any case, that leaves the location of the IDE configuration files on Linux.

RaiMan (raimund-hocke) said : #3

ok, you have to dig into the RobotFramework options, to find out, how to stop it from displaying the report.
Seems to be a standard action. I cannot guarantee, that it is possible in this setup.

The feature is experimental and has to be used at your own risk.

zingmars (zingmars) said : #4

Actually, this is definitely SikuliX and not Robot Framework. First of all, Robot FW does not call robot.rebot by default, it has to be done manually. It also doesn't help that you're shipping a slightly modified version of Robot (although I assume the changes stop at comments like https://i.imgur.com/l2fHxgT.png).
Either way, see this line - https://github.com/RaiMan/SikuliX1/blob/6fd5177ef6a6d023837cbd9ef4a804be8a022c81/API/src/main/java/org/sikuli/script/Runner.java#L539

Best RaiMan (raimund-hocke) said : #5

Uuuups, long time ago since my last contact with this stuff. Not my priority currently and experimental as mentioned.

Anyways thanks for the investigation and finding.

I will fix it tomorrow and add adoption somehow.

zingmars (zingmars) said : #6

Thanks RaiMan, that solved my question.