How to user sikulix 1.1.1(sikulixapi.jar) in Maven

Asked by Vin Uppinkudru on 2018-02-12

Hi Raiman,
I am having difficulty in using Sikulix version 1.1.1

Steps I followed are as below
1. Added sikulix pom as below
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>

    <groupId>com.sikuli.maven</groupId>
    <artifactId>sikuli-maven</artifactId>
    <version>1.0.0</version>
    <dependencies>
        <dependency>
            <groupId>com.sikulix</groupId>
            <artifactId>sikulixapi</artifactId>
            <version>1.1.1</version>
        </dependency>
    </dependencies>
</project>
2. Clean and Install
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 4.836 s
[INFO] Finished at: 2018-02-12T23:05:57+11:00
[INFO] Final Memory: 11M/111M
[INFO] ------------------------------------------------------------------------

Process finished with exit code 0
3. Now I try to use sikuli script in my program
However, the below import in the code is not working. Cannot resolve symbol sikuli

import org.sikuli.script.*;
public class TestSikuli {
}

I am missing something here. Appreciate your kind help

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Vin Uppinkudru
Solved:
2018-02-14
Last query:
2018-02-14
Last reply:
2018-02-13
RaiMan (raimund-hocke) said : #1

That is not Maven-like!

SikuliX must be a dependency in YOUR Maven project.

If you are not familiar with Maven, then you should run setup to get a sikulixapi.jar, that you use in your project as a library (on Java class path) depending on your developement environment.

Vin Uppinkudru (neouppin) said : #2

Hi Raiman,
This maven dependency was correct, some kind of IDE issue. Able to pull down the sikulix-1.1.1. Thanks