Sikulix Crash

Asked by Jeff_Vallis on 2018-01-27

Does this mean anyting to anyone - Running Sikuli from the command line

/Applications/Sikuli/runsikulix: line 21: 2352 Abort trap: 6 java $PROPS -Xdock:icon="$icon" -Xdock:name=SikuliX -jar "$sjar" $SIKULI_COMMAND

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2018-02-01
Last query:
2018-02-01
Last reply:
2018-01-30
Jeff_Vallis (vallis-pj) said : #1

1.1.1(2017-03-30_01:00)/Mac10.13.2/Java8(64)1.8.0_25-b17

oops missed this

RaiMan (raimund-hocke) said : #2

looks odd for 1.1.1:

- it should be /Applications/SikuliX.app
- it should be /Applications/SikuliX.app/run

So my guess, you have an additional folder
 /Applications/Sikuli

that contains the runsikulix shell script and this is called from another application/script/whatever, but not directly from a Terminal session.

So be more specific about your setup.

Jeff_Vallis (vallis-pj) said : #3

More Details
It is run daily and the above error has only happened twice in the last 6 months
Details of how the Script is Run
1. The Script is Executed by "Power Manger" which allows you to Schedule Tasks
2. Power Manager executes the following script in Terminal as an Applescript.
#!/usr/bin/osascript

tell application "Terminal"
 do script "/Users/Jeff/Desktop/SikuliScripts/Startup/Startup_A_First.cmd >> /Users/Jeff/Desktop/MyLog_Startup.txt"
end tell
3. /Users/Jeff/Desktop/SikuliScripts/Startup/Startup_A_First.cmd does many commands one of which is
/Applications/Sikuli/runsikulix -r /Users/Jeff/Desktop/SikuliScripts/Run_Startup_Both.sikuli >> /Users/Jeff/Desktop/SikuliScripts/This_log.txt

Summary:
It Runs Daily the vast majority of times without an error - failed twice in 6 months.
I

Best RaiMan (raimund-hocke) said : #4

Twice in 6 months looks like a system hick-up to whatever reason.

stackoverflow
https://stackoverflow.com/questions/40878851/abort-trap-6-error-in-c-mac-terminal
quote """
The error means you are writing to memory you don't own. Will likely happen if you try to copy a string longer than the one you specified for food ('pizza'). In this case it could be cos you are copying the string into memory location assigned to a string constant.
"""

In this very complex setup of issuing different "commands" in different environments there might be a glitch somewhere in the used components.

Since it is annotated to the java command used in runsikulix it must be some problem with the java startup, probably related to the special -X... settings.

Though not knowing your complete setup, I guess, to do all this less complex might be using a main SikuliX script that uses run, runscript and Popen.subprocess to do the rest.
PowerManger the would only run the main via runsikulix.
Such a setup would give you more possibilities to control failure situations.

... but might not be worth, to get rid of something, that happens twice in six months.

You might think of some wrapping, that tries to repeat the failing command in that situation.

Jeff_Vallis (vallis-pj) said : #5

Thanks RaiMan, that solved my question.