Having problems using Rational Application Developer for Websphere

Asked by Praveen Reddy on 2017-11-25

Hi RaiMan,

Since my internal downloads are blocked in my system, i tried an Offline Setup as per below link steps. But still i'm getting below Error when i'm running my code. I've configured my SikuliAPI.jar file into my java project. Please help me on this.

http://sikulix.com/specials/files/c77aee9efb9985e68684cf70bbaa21a9-3.html

Error Logs:

[TestNG] Running:
  C:\Users\Kumar\IBM\rationalsdp\workspace\RoughWork\testng.xml

[error] RunTimeINIT: Java version not detected (using 7): pwi3270sr7fp1-20140712_01 (SR7 FP1)
java ?7?-32 version pwi3270sr7fp1-20140712_01 (SR7 FP1) vm 2.6 class 51.0 arch x86

*** system properties dump
com.ibm.oti.vm.bootstrap.library.path = C:\IBM\SDP\jdk\jre\bin\default;C:\IBM\SDP\jdk\jre\bin
com.ibm.vm.bitmode = 32
com.ibm.zero.version = 2
java.class.path = C:\IBM\SDP\plugins\org.testng.eclipse_6.11.0.201703011520\lib\testng-remote.jar;C:\Users\KUMAR\IBM\rationalsdp\workspace\RoughWork\target\test-classes;C:\Users\KUMAR\IBM\rationalsdp\workspace\RoughWork\target\classes;C:\Downloads\sikulixapi.jar;C:\Users\KUMAR\.m2\repository\org\apache\poi\p
....................
java.class.version = 51.0
java.compiler = j9jit26
java.endorsed.dirs = C:\IBM\SDP\jdk\jre\lib\endorsed
java.ext.dirs = C:\IBM\SDP\jdk\jre\lib\ext
java.fullversion = JRE 1.7.0 IBM J9 2.6 Windows 7 x86-32 20140627_204598 (JIT enabled, AOT enabled)
J9VM - R26_Java726_SR7_20140627_0924_B204598
JIT - r11.b06_20140409_61252.04
GC - R26_Java726_SR7_20140627_0924_B204598
J9CL - 20140627_204598
java.home = C:\IBM\SDP\jdk\jre
java.io.tmpdir = C:\Users\KUMAR\AppData\Local\Temp\1\
java.runtime.name = Java(TM) SE Runtime Environment
java.runtime.version = pwi3270sr7fp1-20140712_01 (SR7 FP1)
java.specification.name = Java Platform API Specification
java.specification.vendor = Sun Microsystems Inc.
java.specification.version = 1.7
java.vendor = IBM Corporation
java.vendor.url = http://www.ibm.com/
java.version = 1.7.0
java.vm.info = JRE 1.7.0 Windows 7 x86-32 20140627_204598 (JIT enabled, AOT enabled)
os.arch = x86
os.encoding = UTF8
os.name = Windows 7
os.version = 6.1
path.separator = ;
sun.arch.data.model = 32
*** system properties dump end

Unhandled exception
Type=Segmentation error vmState=0x00040000
J9Generic_Signal_Number=00000004 ExceptionCode=c0000005 ExceptionAddress=67CC737B ContextFlags=0001003f
Handler1=67CB0120 Handler2=686EEF70 InaccessibleAddress=00000008
EDI=04DA0894 ESI=00000000 EAX=00000000 EBX=0064E300
ECX=00000020 EDX=2FF81398
EIP=67CC737B ESP=034BF1E0 EBP=034BF238 EFLAGS=00010246
GS=002B FS=0053 ES=002B DS=002B
Module=C:\IBM\SDP\jdk\jre\bin\default\j9vm26.dll
Module_base_address=67CA0000 Offset_in_DLL=0002737b
Target=2_60_20140627_204598 (Windows 7 6.1 build 7601 Service Pack 1)
CPU=x86 (2 logical CPUs) (0x15ff8e000 RAM)

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2017-11-25
Last reply:
2017-11-30
RaiMan (raimund-hocke) said : #1

I am converting this to a question, since I do not accept it as a SikuliX bug

ok RaiMan fine but, its similar to Eclipse IDE: Java EE not sure how it differs. So will this Question be resolved? If Yes, please let me know ETA, otherwise i may need to find alternatives, because its little urgent for me. Thanks

RaiMan (raimund-hocke) said : #3

So if it is similar to Eclipse IDE, then you only have to
- run setup 1.1.1 or 1.1.2 with option 2 to get a sikulixapi.jar
- put a reference to this sikulixapi.jar into your project's context classpath
- run a simple Java App with a main() containing only Screen scr = new Screen() with -Dsikuli.Debug=3 on the java commandline (project run context)

Hi RaiMan, I've tried it but i got the same Error as i mentioned in the Bug description.

RaiMan (raimund-hocke) said : #5

any debug output before the crash?

I didn't get any such apart from that

RaiMan (raimund-hocke) said : #7

ok, then I have to leave you alone with your problem.

I have no idea how to help you.

Can you help with this problem?

Provide an answer of your own, or ask Praveen Reddy for more information if necessary.

To post a message you must log in.