Unable to click Yes button on Install sheild wizard popup

Asked by Test App on 2017-11-15

Hi ,

I am using Sikuli to install and uninstall my desktop application from Control panel
I Navigate to control panel Click on my application , Click on Uninstall button

On clicking Uninstall button , a window with YES and NO buttons is displayed . I have tried multiple approaches but none of them seem to work

Approach 1 :

click (image1)

Sikuli clicks as shown in logs , but in reality nothing happens

Approach 2:
hover(image)
click(image) or click (image - Capture a larger region and apply Target offset)

Nothing happens

Approach 3:

#As the button is already in focus

type(Key.ENTER)

No use

However approach 1 & 2 work fine when i run the script from remote , But on my local i do not understand why i cannot click on the Yes button

And i have run all these tests as Administrator

Please help

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Test App
Solved:
2017-11-15
Last query:
2017-11-15
Last reply:
2017-11-15
TestMechanic (ndinev) said : #1

Tried on windows 8.1 and works for me. Provide more details ... maybe app that need to be uninstalled

Test App (laxmisaketha) said : #2

Problem solved

I have tried to change the focus and then clicked on the Enter Key , So works fine now

TestMechanic (ndinev) said : #3

This is common problem in windows. However in my experience using .highlight() method can cause this behavior in some cases

Test App (laxmisaketha) said : #4

Yes ndinev

Thanks