dragDrop not working as expected

Asked by aravind on 2017-10-31

I am trying to develop a UI test suite for a GUI application. My launcher module looks like this

from sikuli import *
import unittest
import HTMLTestRunner
Settings.MoveMouseDelay = 0
Settings.TypeDelay = 0
Settings.ClickDelay = 0
def ClickOrtho(img):
    start=Env.getMouseLocation()
    end=find(img)
    mouseMove(Location(end.x,start.y))
    mouseMove(Location(end.x,end.y))
    click(end)
    return end
#open the application
def test_1_right(self):
 import one
.
.
.
.
.
.

The problem is one of my test script uses dragDrop() , when I run that test script discretely It is working as expected but when I run the main UI script the particular case is getting stuck at dragDrop(). (The function has successfully dragged the content and reached near destination but It is not dropping the item at destination) as a result the next statement is getting failed.

Note: I am pretty sure that the present test case is not getting failed because of previous test case. and also tried by removing click delay, mouse delay and type delay

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
aravind
Solved:
2017-11-01
Last query:
2017-11-01
Last reply:
2017-10-31
RaiMan (raimund-hocke) said : #1

--- one of my test script uses dragDrop()
... cannot see where

aravind (aravind981) said : #2

Solved it after I found this doc http://sikulix-2014.readthedocs.io/en/latest/scripting.html?highlight=mouse%20delay ,Thanks for the response