Not able to open Sikuli IDE on Ubuntu 16.04

Asked by venkatesh on 2017-10-23

I have installed Sikuli 1.1.0 on Ubuntu 16.04 , but im getting error as
[error] RunTimeIDE:*** terminating :command 'xdotool' is not executable
please check the Availability!

I already installed xdotool, but still im getting this error

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2017-10-23
Last reply:
2017-10-23
RaiMan (raimund-hocke) said : #1

please try version 1.1.1

venkatesh (venkat6840) said : #2

When i tried to install 1.1.1 , im getting a message as "java version must be 1.7 or later!" , but i already installed
java version 1.8.0_144

RaiMan (raimund-hocke) said : #3

Java 6 also on your machine?
Java 8 active/selected at time of setup?
Oracle Java or OpenJDK Java?

venkatesh (venkat6840) said : #4

im using ibm licensed JDK , its not OpenJDK

java version "1.8.0_144"
Java(TM) SE Runtime Environment (build 8.0.5.0 - pxa6480sr5-20170905_01(SR5))
IBM J9 VM (build 2.9, JRE 1.8.0 Linux amd64-64 Compressed References 20170901_36 3591 (JIT enabled, AOT enabled)
J9VM - d56eb84
JIT - tr.open_20170901_140853_d56eb84
OMR - b033a01)
JCL - 20170823_01 based on Oracle jdk8u144-b01

RaiMan (raimund-hocke) said : #5

ok, pleas run the IDE using:
java -jar sikulix.jar -d 3

... and look in the debug output for the section between
***** show environment for IDE
...
***** show environment for IDE

there should be a line having something like this:
java 8-64 version 1.8.0_121-b13 vm 25.121-b13 class 52.0 arch x86_64

please report what you have.

venkatesh (venkat6840) said : #6

***** show environment for IDE (build 201510051707)
user.home: /root
user.dir (work dir): /opt/Sikuli
user.name: root
java.io.tmpdir: /tmp
running 64Bit on Linux (0 Ubuntu 16.04) from a jar
java 0-64 version 8.0.5.0 - pxa6480sr5-20170905_01(SR5) vm 2.9 class 52.0 arch amd64
app data folder: /root/.Sikulix
libs folder: /root/.Sikulix/SikulixLibs_201510051707
executing jar: /opt/Sikuli/sikulix.jar
*** classpath dump sikulix
  0: /opt/Sikuli/sikulix.jar
*** classpath dump end
***** show environment end

RaiMan (raimund-hocke) said : #7

ok, the problem is, that your IBM Java does not report the version as Oracle and OpenJDK Java do.
It is the System property java.runtime.version, that usually looks like 1.8....., but with your Java it looks like 8.....

Since there is no way, to adjust this setting from outside, you have to wait, until I have added a workaround in version 1.1.2.

I will make this a bug.
Just watch my activities.

venkatesh (venkat6840) said : #8

so for Sikuli 1.1.1 fix of java 8 i will wait for 1.1.2 version , is there any workaround for Sikuli 1.1.0 as xdotool is already installed on my system , but still im getting error as
[error] RunTimeIDE:*** terminating :command 'xdotool' is not executable

Can you please provide any workaround for this error ?

RaiMan (raimund-hocke) said : #9

please look at the related bug and use version 1.1.2.

RaiMan (raimund-hocke) said : #10

The xdotool problem is solved in version 1.1.x

Can you help with this problem?

Provide an answer of your own, or ask venkatesh for more information if necessary.

To post a message you must log in.