Cannot share scripts from my computer to my co-worker's computer

Asked by Nicholas Gaudet on 2017-07-10

I created a script that works perfectly fine on my computer. We wanted to do testing on multiple computers, so we exported my script and downloaded it on another computer to test it out. The location and image detection do not work at all.
a) the pictures are completely ignore and aren't getting recognized even though we're using the very same laptops with the very same resolution and display settings.
b)the location on mine works fine, but on my co-workers, when I transfer my script, his area of searching shrinks and thus the location does not work.
Is there a special setting I have to enable? I have tried everything and looked online for HOURS with absolutely no results and so progress.

Question information

Language:
English Edit question
Status:
Expired
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2017-07-11
Last reply:
2017-07-27
RaiMan (raimund-hocke) said : #1

to find an image in another environment, the image displayed there must have the same dimensions in pixels as the image captured before on the other system.

If resolution and display settings are the same, then the only reason can be some different rendering caused by software (e.g. browser) which influences dimension in pixels and image content (mostly towards/around) the edges.

images with much background, that differs on the other system can be the cause too. (background pixel count should be below 20% compared to the pixel count of the whole image)

read:
http://sikulix-2014.readthedocs.io/en/latest/basicinfo.html#sikulix-how-does-it-find-images-on-the-screen

Nicholas Gaudet (ordealofnick) said : #2

We made sure everything is the same, our computers are completely identical as far as we know, what seems to be the issues is the region that Sikli is looking for is MUCH smaller on my coworker's computer. When I click the "Take Screenshot" area on the app, everything works fine for me, but when my coworker does it on his, the screen "shrinks", reducing the search area on his laptop.

Nicholas Gaudet (ordealofnick) said : #3

Upon further investigation, the error is that on the other computers, when their display zoom is set at 100% (Windows), their screen shrinks and the search area is completely disproportionate, which is why it can't find the photos. We tried reinstalling but nothing works.

TestMechanic (ndinev) said : #4

That's strange. I am using images recorded on one machine to run on win7 win8 win10 (mac and linux with some limitations). Also resolutions vary from full HD to 1024x768 without a problem.(some tweaks are need in testing logic but it is ok)
I am interested what is the case here.

here are some questions:
-- what is the display resolution of the laptop - you can share the model name
-- what is the OS of the laptops
-- do you have any extended displays
-- confirm that display setting of fonts sizes are 100%
-- confirm video driver is up to date
-- when capturing image does gray area cover all the screen

here are some some ideas:
-- check for conflicting software - video related software - like video capture
-- check java versions - what are the versions
-- capture image let say of google icon on both PC and compare them manually visually
-- set both laptop to some lower resolution - like 1280x800 and try again
-- capture areas with circle(s) and check if they look circles on other laptop(you mention disproportion)
-- seems you are using regions - can you try without them

Launchpad Janitor (janitor) said : #5

This question was expired because it remained in the 'Open' state without activity for the last 15 days.