Run Sikuli on Jenkins Window Batch Command Issue

Asked by Jp17 on 2017-07-04

Hi,

I have set up the Jenkins Slave node and is connected in my project configuration I have chose Build - Execute Windows batch command - see below:

C:\Program Files (x86)\Sikuli X\Sikuli-IDE-w.bat -r C:\SikuliX\MotorTrade.sikuli

but when I click on Build Now a list appeared on my screen showing and the build failed:

at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at org.python.core.Py.loadAndInitClass(Py.java.895)
.....
and so on

To close this list I must close it via Window Task Manager.

Could someone please tell me what I need to do to resolve this?

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2017-07-06
Last query:
2017-07-06
Last reply:
2017-07-05
Jp17 (jlin17) said : #1

Just to mention I have tried with Sikuli Script X-1.0rc3 (http://www.sikuli.org/downloadrc3.html) and I am getting the same list but the Build is success but I cannot see anything opening on my screen and the HTML Report in my Sikuli folder has not been updated.

RaiMan (raimund-hocke) said : #2

Upgrade your environment to version 1.1.1

X-1.0rc3 is no longer supported.

Jp17 (jlin17) said : #3

Thanks I will give a go.

Jp17 (jlin17) said : #4

Hi RaiMan,

I have changed it to version 1.1.1 following is my code in the Jenkins Window Batch Command:

cd C:\SikuliX\
C:\SikuliX\Sikuli-IDE-w.bat -r TestFolder.sikuli

I ran a build it says success but when I go to the Testfolder.sikuli and check the HTML report there is no change. Could you please tell me if I need to add anything else to the setting?

Thanks

Best RaiMan (raimund-hocke) said : #5

Please be sure you have read and understood:
- http://www.sikulix.com/quickstart/
- http://sikulix-2014.readthedocs.io/en/latest/basicinfo.html#some-general-aspects
- http://sikulix-2014.readthedocs.io/en/latest/faq/010-command-line.html#how-to-run-sikulix-from-command-line

Take care, that NOTHING from older versions is used nor referenced anywhere (e.g. system environment)

Jp17 (jlin17) said : #6

Thanks RaiMan, issue resolved per your instruction removed all older versions from system environment and used runsikuli.cmd instead.

Jp17 (jlin17) said : #7

Thanks RaiMan, that solved my question.