Mouse Actions are Blocked [UBUNTU DESKTOP VPS]

Asked by Jas on 2017-07-03

I am running sikuli script written in Java on my virtual desktop VPS (running ubuntu). The VPS is setup so that the ubuntu desktop is accessed using NoMachine. My program is a combination of sikuli script and selenium. Selenium portion of my program works fine but sikuli is unable to click anywhere for some reason.

Error -> https://pastebin.com/raw/enSj3VaM

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Jas
Solved:
2017-07-04
Last query:
2017-07-04
Last reply:
2017-07-03
RaiMan (raimund-hocke) said : #1

be sure to use the latest SikuliX version 1.1.1

Jas (ox02) said : #2

I can confirm I'm using ver. 1.1.1.

RaiMan (raimund-hocke) said : #3

Ok, then you have to check your VM settings about the Mose behavior.

Before you go further, you should simply test, wether SikuliX can click the center of the screen at all.

new Screen(0).click(); // should click the center

Jas (ox02) said : #4

[info] runcmd: lsb_release -i -r -s
libdc1394 error: Failed to initialize libdc1394
[error] RobotDesktop: checkMousePosition: should be L(683,384)@S(0)[0,0 1366x768]
but after move is L(346,191)@S(0)[0,0 1366x768]
Possible cause in case you did not touch the mouse while script was running:
 Mouse actions are blocked generally or by the frontmost application.
[log] CLICK on L(683,384)@S(0)[0,0 1366x768] (529 msec)

^new Screen(0).click();

Jas (ox02) said : #5

does anyone know what I would potentially have to change. Im running NoMachine / Gnome Virtual Desktop.

Jas (ox02) said : #6

I ended up reinitializing the VPS. Instead of NoMachine@Ubuntu 12.04 I just updated to 16.04 and went with XRDP instead. Works now. I assume NoMachine was blocking the mouse events. Thanks anyways.