Win10 doesn’t render RDP sessions when local screen locked

Asked by James on 2017-06-14

With Windows 7 I was able to RDP into a test machine running Server 2012, kick off a sikuli script, and then lock my local Win7 client’s screen. Windows would continue to render the RDP session (with the screen locked) and sikuli would be able to see images without issue.
Now that my local machine is Win10, however, it will no longer continue to render the RDP session when the screen is locked so all Sikuli image searches fail. Does anybody know if there a workaround to get this to work with Win10? Display settings and video card settings have had no effect.

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
masuo
Solved:
2017-06-15
Last query:
2017-06-15
Last reply:
2017-06-14
Best masuo (masuo-ohara) said : #1

There is a similar question.
How to continue script running when RDP window minimized.
https://answers.launchpad.net/sikuli/+question/213636

Your case may be different from this, but for your reference.

James (pbcomm) said : #2

masuo, you are the man. The registry key RemoteDesktop_SuppressWhenMinimized solved my problem. Not only can I run scripts through a minimized RDP session, but I can also lock the local client now.

Thank you!