Script project has no script file MyFile.xxx

Asked by Fabián Frommel on 2017-06-12

Hello everyone,

I just started using Sikuli for some automatic tests over webpages developed by the company where I work. I wrote a test in one machine, and it ran OK, but when I want to use the same test from other PC, I'm having this error:

"FileManager: Script project /tmp/Sikulix_16148351/MyTest.xxx"

No matter from where I run the program: From IDE or command terminal with "./runsikulix -r MyTest.skl" I have the same error.

I hope you could help me. Many thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Fabián Frommel
Solved:
2017-06-15
Last query:
2017-06-15
Last reply:
Fabián Frommel (ffrommel) said : #1

UPDATED:
I wrote another test and generated a .skl file. Now, when I try to execute it from terminal, I see the following messages:

./runsikulix -r ./tests/MyTest2.skl
Running SikuliX: -Xmx512M -Dfile.encoding = UTF-8 -Dsikuli.FromCommandLine
-jar ./sikulix.jar -r ./tests/TestCREA2.skl
[Info] runcmd: lsb_release -i -r -s

Then it end and the prompt is given back.

Thank you very much again!

Fabián Frommel (ffrommel) said : #2

If you overwrite a .skl test from IDE, you have not to put .skl at the end!