Had Sikuli running about a year ago, but tried to reinstall recently and received the following error log

Asked by Sam on 2017-05-18

Any insight is greatly appreciated, thanks.

[debug (5/18/17 8:08:28 AM)] Debug: setLogFile: D:\SikuliAttempt2017\SikuliX-1.1.1-SetupLog.txt
[debug (5/18/17 8:08:28 AM)] RunSetup: ... starting with no args given
[debug (5/18/17 8:08:28 AM)] RunSetup: Setup: 1.1.1 2017-03-29_10:41 in folder:
D:\SikuliAttempt2017
[debug (5/18/17 8:08:29 AM)] RunSetup: RunningSystem: Windows 6.1
[debug (5/18/17 8:08:29 AM)] RunSetup: parent of jar/classes: D:\SikuliAttempt2017
[debug (5/18/17 8:08:29 AM)] RunSetup: RunningJava: Java 8 (x86) 1.8.0_101-b13
[debug (5/18/17 8:08:29 AM)] init user preferences
[debug (5/18/17 8:08:38 AM)] RunSetup:
popAsk: --------------------
The following file(s) will be downloaded to
D:\SikuliAttempt2017
--- Native support libraries for Windows (sikulixlibs...)
--- Package 1 ---
null (IDE/Scripting)
null (Java API)
 - with Jython
Only click NO, if you want to terminate setup now!
Click YES even if you want to use local copies in Downloads!
--------------------
[debug (5/18/17 8:08:42 AM)] FileManager: download to string from:
https://oss.sonatype.org/content/groups/public/com/sikulix/sikulixlibswin/1.1.1-SNAPSHOT/maven-metadata.xml,
[error (5/18/17 8:08:42 AM)] FileManager: problems while downloading
java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[error (5/18/17 8:08:42 AM)] RunSetup: Maven download: could not get timestamp nor buildnumber for sikulixlibswin from:
https://oss.sonatype.org/content/groups/public/com/sikulix/sikulixlibswin/1.1.1-SNAPSHOT/maven-metadata.xml
with content:

[debug (5/18/17 8:08:42 AM)] FileManager: download to string from:
https://oss.sonatype.org/content/groups/public/com/sikulix/sikulixsetupAPI/1.1.1-SNAPSHOT/maven-metadata.xml,
[error (5/18/17 8:08:43 AM)] FileManager: problems while downloading
java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[error (5/18/17 8:08:43 AM)] RunSetup: Maven download: could not get timestamp nor buildnumber for sikulixsetupAPI#forsetup from:
https://oss.sonatype.org/content/groups/public/com/sikulix/sikulixsetupAPI/1.1.1-SNAPSHOT/maven-metadata.xml
with content:

[debug (5/18/17 8:08:43 AM)] FileManager: download to string from:
https://oss.sonatype.org/content/groups/public/com/sikulix/sikulixsetupIDE/1.1.1-SNAPSHOT/maven-metadata.xml,
[error (5/18/17 8:08:43 AM)] FileManager: problems while downloading
java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[error (5/18/17 8:08:43 AM)] RunSetup: Maven download: could not get timestamp nor buildnumber for sikulixsetupIDE#forsetup from:
https://oss.sonatype.org/content/groups/public/com/sikulix/sikulixsetupIDE/1.1.1-SNAPSHOT/maven-metadata.xml
with content:

[debug (5/18/17 8:08:43 AM)] RunSetup:
popAsk: --------------------
If you click YES, you will get Jython version 2.7.0 (recommended)
... but in rare cases there might be issues with UTF-8/Unicode
that usually appear on startup when UTF-8 characters
are present somewhere in the system environment
If you encounter such problems with Jython 2.7.0
run setup again and
click NO to get Jython 2.5.4rc1
--------------------
[debug (5/18/17 8:08:48 AM)] FileManager: Downloading jython-standalone-2.7.0.jar with unknown size
[error (5/18/17 8:08:49 AM)] FileManager: problems while downloading
javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[debug (5/18/17 8:08:52 AM)] RunSetup: Download ended
[debug (5/18/17 8:08:52 AM)] RunSetup: Downloads for selected options:
null null null jython-standalone-2.7.0.jar
[debug (5/18/17 8:08:52 AM)] RunSetup:
popError: --------------------
Some of the downloads did not complete successfully.
Check the logfile for possible error causes.
If you think, setup's inline download is blocked somehow on
your system, you might download the appropriate raw packages manually
into the folder Downloads in the setup folder and run setup again.
files to download (information is in the setup log file too)
null
null
null
jython-standalone-2.7.0.jar
Be aware: The raw packages are not useable without being processed by setup!
For other reasons, you might simply try to run setup again.
--------------------
[error (5/18/17 8:09:02 AM)] RunSetup: download not completed successfully
[error (5/18/17 8:09:02 AM)] RunSetup: ... terminated abnormally :-(
[debug (5/18/17 8:09:02 AM)] RunSetup:
popError: --------------------
Something serious happened! Sikuli not useable!
Check the error log at D:\SikuliAttempt2017\SikuliX-1.1.1-SetupLog.txt
--------------------
[debug (5/18/17 8:09:06 AM)] RunTimeSETUP: final cleanup
[debug (5/18/17 8:09:07 AM)] FileManager: deleteFileOrFolder:
C:\Users\xxxxx\AppData\Local\Temp\Sikulix_1766375890

Question information

Language:
English Edit question
Status:
Needs information
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2017-05-18
Last reply:
2017-05-18
RaiMan (raimund-hocke) said : #1

You seem to have some security problems in your environment with inline downloads.

You might try the offline setup:
http://www.sikulix.com/specials/files/c77aee9efb9985e68684cf70bbaa21a9-3.html

Sam (staffo08) said : #2

Thanks, I've tried the offline installation and everything seemed like it went okay, but on launch I'm seeing the following before the cmd window disappears completely.

Warning: Could not open/creaet prefs root node Software\JavaSoft\Prefs at root 0 x800000002. Windows RegCreateKeyEx(...) returned error code 5.
[info] HotkeyManager.......
[error] WindowsHotkeyManager: Jintellitype problem: Could not load Jintellitype.dll form local file system or from the JAR.

Is the error simply that I'm missing JIntellitype.dll for some reason? What would be the best way to rectify this?

Thanks again

RaiMan (raimund-hocke) said : #3

is it 32-Bit or 64-Bit?

The warning can be ignored.

please run in a commandprompt:
runsikulix.cmd -c -d 3

and send me the debug output to sikulix--at--outlook--dot--com

Can you help with this problem?

Provide an answer of your own, or ask Sam for more information if necessary.

To post a message you must log in.