Cant explain CTRL-C behaviour with VNC Screen/Robot

Asked by Rudra on 2017-05-04

I am using VNCScreen to perform some actions/retrieve some data. After the robot does CTRL-C, the clipboard does not receive any data. But if a VNC client is open (tried tightvnc as well as tigervnc) to the same destination when my program is running, CTRL-C puts data successfully into clipboard.

Can someone shed any light?

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Rudra
Solved:
2017-05-04
Last query:
2017-05-04
Last reply:
2017-05-04
RaiMan (raimund-hocke) said : #1

I am not sure, wether the "transfer-clipboard-content" is implemented in the VNCScreen/Robot implementation, since this is a special top-level service between VNC-Client/Server.

Have you tried with the latest SikuliX 1.1.1?

If yes, I do not have the time to check this myself in the code. Has to wait until later next week.

Rudra (rudrajyoti) said : #2

Hi Raimund, Thanks for the pointer. It was indeed the case. "serverCutText" of CMsgHandler is not implemented by VNCClient. Reason I was able to get the copied data from my program when a separate VNC Viewer was on is obvious, the vnc viewer implemented the "transfer clipboard content functionality" and was putting the copied text on to the system clipboard.

Please let us know if there's any plan for exposing copied text from vnc server in the near future.

RaiMan (raimund-hocke) said : #3

I made it a bug and as mentioned: somewhen next week, I will dive into and hopefully find a solution.

Since you are subscribed to the bug, you will get notes of changes automatically.