SikulixLibrary for Robot Framework constantly throws the same exception

Asked by Emil Pelchat on 2017-04-18

On Centos 6, the SikulixLibrary for Robot Framework keeps throwing the following error:
11078 [qtp1556956098-27] ERROR org.apache.xmlrpc.server.XmlRpcErrorLogger - No such handler: get_keyword_tags

It does this repeatedly as it runs. After a while it tends to break in one of several ways, but that may be unrelated. A quick google tells me that either the server isn't getting a method call, or is getting the wrong method call from Robot Framework.

I'm using the most updated version of SikulixLibrary from git, 0.1.5, and I think I've installed it right, although initially it installed the version of the jar with the windows library rather than linux, but I fixed that. (That was from "python install" that installed the windows jar)

Could this be causing the problems I have where Sikuli after a few runs fails to recognize some images, and click in the wrong place for others until I restart the server?

Question information

English Edit question
Sikuli Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Best RaiMan (raimund-hocke) said : #1

you should post your question on the github page as isssue.

I doubt that the developer or the community will read it hear.

Emil Pelchat (chthonicone) said : #2

Thank you, I was confused because one of the developers over there has a similar name to you, "Rainmanwy." I saw that and thought you must be the same person.

Emil Pelchat (chthonicone) said : #3

Thanks RaiMan, that solved my question.