HowTo: Linux: install SikuliX: centos-release-6-7.el6.centos.12.3.x86_64 --- use SikuliX version 1.1.1

Asked by Jeevan S on 2017-03-24

Hi ,

I followed this article and only change is that I installed Oracle Java 8 as my selenium project was built on Java 8.

When I try to follow Step 4 "Install the previously downloaded packages." from above link
sudo rpm -ivh opencv245-core-2.4.5-1.sdl6.x86_64.rpm is successfully installed and rest of them are failing saying dependent packages are required .

OS - centos-release-6-7.el6.centos.12.3.x86_64

warning: opencv245-2.4.5-1.sdl6.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 41a40948: NOKEY
error: Failed dependencies: is needed by opencv245-2.4.5-1.sdl6.x86_64 is needed by opencv245-2.4.5-1.sdl6.x86_64
warning: liblept3-1.69-7.1.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 71988a58: NOKEY
error: Failed dependencies: is needed by liblept3-1.69-7.1.x86_64 is needed by liblept3-1.69-7.1.x86_64 is needed by liblept3-1.69-7.1.x86_64 is needed by liblept3-1.69-7.1.x86_64 is needed by liblept3-1.69-7.1.x86_64
warning: tesseract-3.02.02-3.2.1.x86_64.rpm: Header V3 RSA/SHA1 Signature, key ID cbdf5e8f: NOKEY
error: Failed dependencies: is needed by tesseract-3.02.02-3.2.1.x86_64 is needed by tesseract-3.02.02-3.2.1.x86_64

Question information

English Edit question
Sikuli Edit question
No assignee Edit question
Last query:
Last reply:
RaiMan (raimund-hocke) said : #1

I generally do not accept bugs on installation problems with non-Ubuntu Linux flavours and SikuliX versions prior to 1.1.1

RaiMan (raimund-hocke) said : #2

Generally you have to try with latest SikuliX version 1.1.1 ( and read:

How to get the needed prereqs (OpenCV, ... on your system) you have to consult the net and communities specific for your Linux flavor.

Jeevan S (jeevan-qa) said : #3


Thanks for the inputs .

I have an automation solution using Sikuli on Windows and now would like to ship it to CentOS 6.7 .

But i'm really finding it difficult to install Sikuli on CentOS 6.7 as I'm not able to find the required libraries in the Net.

For Eg says we need to have Tesseract 3.0.2+ , But unfortunately there was not any yum packages available for 6.7 . Hence i went with rpm installation but again ending up with errors related to dependent packages .


--> Finished Dependency Resolution
Error: Package: tesseract-3.02.02-3.2.1.x86_64 (/tesseract-3.02.02-3.2.1.x86_64)
Error: Package: tesseract-3.02.02-3.2.1.x86_64 (/tesseract-3.02.02-3.2.1.x86_64)


Could you please point me in the right direction to find the solution for this ?


RaiMan (raimund-hocke) said : #4

Since here there are surely not so many CentOS experts around, you have to look for help at suitable places in the net elsewhere.

I definitely cannot help you.

Can you help with this problem?

Provide an answer of your own, or ask Jeevan S for more information if necessary.

To post a message you must log in.