Is there any Command to run sikuli without opening ide in ubuntu .

Asked by Sukrutha on 2017-03-24

Is there any Command to run sikuli without opening ide in ubuntu .
we tried the command : sikuli-path/runsikulix --run sikuli folder/file
By running the above command it still opening ide.

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2017-03-27
Last reply:
2017-03-27

According to documentation ( http://sikulix-2014.readthedocs.io/en/latest/faq/010-command-line.html )

PATH-TO-SIKULIX/runsikulix -r,--run <sikuli-folder/file> (one or more entries seperated by space)

run one or more .sikuli or .skl files one after the other

Sukrutha (sukrutha1) said : #2

Thank you @podolyan-roman for trying to help me
But the command "PATH-TO-SIKULIX/runsikulix -r,--run <sikuli-folder/file> " still opens the sikuli IDE but with the given file/folder.I already mentioned this in my question.
I want sikuli scripts to get automatically triggered by a command from terminal rather an IDE getting opened and then I press the run button on IDE to run the scripts.

RaiMan (raimund-hocke) said : #3

assuming you are using the latest SikuliX 1.1.1

- runsikulix should work as mentioned

- try this on a commandline (taken from the shell script above):

java -jar <path-to>/sikulix.jar -r <path-to>/someScript.sikuli

... where .sikuli might be omitted (but must exists as <path-to>/someScript.sikuli with a valid someScript.py contained)

the latter is tested on Mac and works (Sikulix 1.1.1)

RaiMan (raimund-hocke) said : #4

if it works with the java command and not with runsikulix, then you can either debug the shell script or make your own with the mentioned java command.

Sukrutha (sukrutha1) said : #5

Both the commands mentioned above are not producing expected result in Ubuntu.
Both the commands java -jar or ./runsikulix are giving the same output i.e,opening the IDE.
I also installed Sikulix 1.1.1 but there is no change (I was using 1.1.0 ).
I also realized that there is no change happening with -r/--run option . Sikuli IDE is only opening by restoring last state and not with expected path given after --run .
Im using Ubuntu 14.04 .Please help me in this issue.

RaiMan (raimund-hocke) said : #6

I just tested with an Ubuntu 16.04-64 with Java 8 and SikuliX 1.1.1:

works as expected

... runsikulix -r ... and the plain java command.

So I guess you have to revise your installation.
Take care, that only the latest SikuliX is used.
At best delete all old stuff.

Can you help with this problem?

Provide an answer of your own, or ask Sukrutha for more information if necessary.

To post a message you must log in.