[1.1.0] macOS: Take screenshot fails --- use version 1.1.1

Asked by Joe Landrigan on 2017-03-17

1.1.0(2015-10-05_17:07)/Mac10.12.3/Java8(64)1.8.0_121-b13

TLDR:
Click "Take Screenshot" --> Flashes a few times, fails to take a screenshot.

Background:
Brand new Mac from work, 1 week old. Sikuli runs acceptably on the old one under essentially the same setup . . . java version is 1.8.0_74-b02, otherwise stats are identical. Running with three monitors: 2 27" monitors and 1 laptop retina display.

Click "Find", "Take Screenshot", "Click", or "Exists" -->

Flash 1: Screen Flashes to "Take Screenshot" mode for less than a second. If I manage to get a screenshot in this time, the screenshot does show up properly; after this, screenshots only show grey.

Flash 2: Screen Flashes but with darker colors than the first time for less than a second. If I capture the screen during this time, I get a screenshot with a grey background.

Flash 3: Screen Flashes almost completely grey but with the words "Select an Image" displaying for a seeming indefinite amount of time. The Dock and the Menu Bar are both fully functional in this mode. (and are full color) Clicking twice or hitting escape twice will exit this mode.

Question information

Language:
English Edit question
Status:
Open
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2017-03-17
Last reply:
2017-03-18

This question was originally filed as bug #1673863.

RaiMan (raimund-hocke) said : #1

use version 1.1.1 (http://sikulix.com)

Can you help with this problem?

Provide an answer of your own, or ask Joe Landrigan for more information if necessary.

To post a message you must log in.