Submenu Disappear when mouse is moved

Asked by Jay Pas on 2017-03-15

The application I am testing runs in a VSphere virtual machine. I am running SikuliX 1.1.0 on windows 7. When I click on the Control button manually, a submenu is displayed with 3 items. Manually, I click on the 3rd item (Restart), which causes the Restart window to be displayed.

In my SikuliX script, I do this:
click("Control.png")
sleep(1)
click("Restart.png")

After the script performs click("Control.png"), I see the submenu. But when it moves the mouse, the menu disappears. Then it clicks on nothing.

I observed that when I manually click the Control button, the submenu is displayed with the first item selected or highlighted. But when the script performs click("Control.png"), the submenu is displayed with none of the items selected or highlighted.

Also, there are times when click("Control.png") does not display the submenu.

Why does the submenu disappear when the mouse is moved?

Thanks,
jaypas

I also want to add that when my co-worker runs the script, it works ok for him. After his script does click("Control.png"), the submenu is displayed with the first item highlighted. Then when it clicks the 3rd item (Restart), the Restart window is displayed.

Also, when I run the script in my office, it works sometimes. But when I am working from home, it never works.

Question information

Language:
English Edit question
Status:
Open
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2017-03-15
Last reply:
2017-03-15
RaiMan (raimund-hocke) said : #1

seems to be a special setup, so please check your various environments for differences.

Jay Pas (jaypas) said : #2

Hi, RaiMan,
Thanks for the response. Can you list what things I should check for in my environment and my co-worker's environment that would cause different behavior?
Thanks,
Jaypas

Can you help with this problem?

Provide an answer of your own, or ask Jay Pas for more information if necessary.

To post a message you must log in.