Could not load JIntellitype, Windows 10 SikuliX 1.1.1

Asked by Guilherme Garia on 2016-12-22

I've been suffering with this issue all day long, I've tried looking for solutions throughout the webs, found some people that had the same issue but trying to solve the way they did didn't work for me.

Debug log:
>runsikulix.cmd -d 3

+++ running this Java
java version "1.8.0_111"
Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)
+++ trying to run SikuliX
+++ using: -Xms64M -Xmx512M -Dfile.encoding=UTF-8 -Dsikuli.FromCommandLine -jar C:\Users\GGARCIA\Desktop\Sikulix\sikulix.jar -d 3
[debug] RunTimeINIT: loadOptions: check: C:\Users\GGARCIA\Desktop\Sikulix
[debug] RunTimeINIT: loadOptions: check: C:\Users\GGARCIA
[debug] RunTimeINIT: loadOptions: check: C:\Users\GGARCIA\AppData\Roaming\Sikulix\SikulixStore
[debug] RunTimeINIT: global init: entering as: IDE
[debug] RunTimeINIT: ScreenDevice 0 has (0,0) --- will be primary Screen(0)
[debug] RunTimeINIT: Monitor 0: (0, 0) 1920 x 1080
[debug] RunTimeINIT: runs as sikulix.jar in: C:\Users\GGARCIA\Desktop\Sikulix
[debug] RunTimeINIT: exists libs folder at: C:\Users\GGARCIA\AppData\Roaming\Sikulix\SikulixLibs_201612100100
[debug] RunTimeINIT: addToWindowsSystemPath: added to systempath:
C:\Users\GGARCIA\AppData\Roaming\Sikulix\SikulixLibs_201612100100
[debug] RunTimeINIT: checkJavaUsrPath: added to ClassLoader.usrPaths
***** show environment for IDE (build 201612100100)
user.home: C:\Users\GGARCIA
user.dir (work dir): C:\Users\GGARCIA\Desktop\Sikulix
user.name: GGARCIA
java.io.tmpdir: C:\Users\GGARCIA\AppData\Local\Temp
running 64Bit on Windows (10.0) from a jar
java 8-64 version 1.8.0_111-b14 vm 25.111-b14 class 52.0 arch amd64
app data folder: C:\Users\GGARCIA\AppData\Roaming\Sikulix
libs folder: C:\Users\GGARCIA\AppData\Roaming\Sikulix\SikulixLibs_201612100100
executing jar: C:\Users\GGARCIA\Desktop\Sikulix\sikulix.jar
*** classpath dump sikulix
  0: /C:/Users/GGARCIA/Desktop/Sikulix/sikulix.jar
*** classpath dump end
***** show environment end
[debug] RunTimeIDE: global init: leaving
[debug] RunTimeIDE: initIDEbefore: entering
[debug] RunTimeIDE: initIDEbefore: leaving
[debug] RunTimeIDE: initAPI: entering
[debug] RunTimeIDE: resourceList: enter
[debug] RunTimeIDE: resourceLocation: (class org.sikuli.ide.SikuliIDE) /Lib/sikuli
[debug] RunTimeIDE: resourceList: having jar: jar:file:/C:/Users/GGARCIA/Desktop/Sikulix/sikulix.jar!/Lib/sikuli
[debug] RunTimeIDE: files exported: 7 from: Lib/sikuli to:
 C:\Users\GGARCIA\AppData\Roaming\Sikulix\Lib\sikuli
[debug] RunTimeIDE: initAPI: leaving
[debug] init user preferences
[debug] IDE: running with Locale: pt_BR
[debug] --- Sikuli parameters ---
[debug] 1: -d
[debug] 2: 3
[info] HotkeyManager: add Capture Hotkey: CTRL+SHIFT 2 (50, 3)
[debug] HotkeyManager: add Capture Hotkey: CTRL+SHIFT 2 (50, 3)
[error] WindowsHotkeyManager: JIntellitype problem: Could not load JIntellitype.dll from local file system or from inside JAR
[debug] RunTimeIDE: final cleanup
[debug] FileManager: deleteFileOrFolder:
C:\Users\GGARCIA\AppData\Local\Temp\Sikulix_1659037070

Currently SO: Windows 10 Pro
Currently Sikulix Version: Nighly Build sikulixsetup-1.1.1-20161210.001637-82

I've tried:
>Different builds (nightly builds, latest release 1.1.0)
>Tried downloading the DLL from https://code.google.com/archive/p/jintellitype/downloads and putting it in:
-->SikuliX Folder
-->Windows System32 folder
-->Inside the JAR file (using winrar)
>Also tried download the DLL available in the GitHub project's page.
>Tried updating my java to the latest version, both Java JDK and JRE. Both 64bit and 32bit.

None of those above worked, i'm really trying to use Sikulix because I think its awesome and will help me a lot, please help me to use it!

Thanks in advance,
GGarcia.

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2016-12-28
Last reply:
2016-12-28
Guilherme Garia (rgui-garcia) said : #1

Oh, I also tried:
>Executing only sikulix.jar, executing it with Open-with (open with java), executing it with java -jar sikulix.jar.

RaiMan (raimund-hocke) said : #3

ok, I will check on my Windows 10 later today.

RaiMan (raimund-hocke) said : #4

Ok, checked on my Windows 10 64Bit and latest Java 8:
- made a setup according to nightly build page
- selected all options
- setup worked fine including the tests
- runsikulix.cmd -d 3 worked as expected (IDE opens)

So check and assure clean environment and purge all old stuff.

If you need an offline setup, then follow the instructions on the nightly page.

Guilherme Garia (rgui-garcia) said : #5

Ok what I did:
 - Uninstalled Java RE 8 32bit, Java RE 8 64 bit | Java SDK 8 32bit, Java SDK 8 64bit
 - Cleaned my PATH for old stuff
 - Downloaded Latest Nightly Build
 - Installed using all the options, putting yes

STILL
NOT
WORKING
Whyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy =(

RaiMan (raimund-hocke) said : #6

ok, delete everything except the sikulixsetup...jar and repeat the setup.

send the setup log file to my mail sikulix--at--outlook--dot--com

Guilherme Garia (rgui-garcia) said : #7

Just sent you, thanks for helping! Once completed lets make a fix for this issue, its been repeating for a while already.

Guilherme Garia (rgui-garcia) said : #8

RaiMan, I never got your answer, my problem is not solved, could you help? :(

RaiMan (raimund-hocke) said : #9

sorry, still christmas holydays this week

Can you help with this problem?

Provide an answer of your own, or ask Guilherme Garia for more information if necessary.

To post a message you must log in.