Hotkey modifiers don't work correctly & F12 hotkey problem

Asked by Alex Lunyov on 2016-12-08

I've made some tests on last 1.1.1 (Win7-64) and revealed the following thing in using Env.addHotkey function:

#1. There is a little mess with key modifier using in addHotkey, for example:

         Env.addHotkey(Key.F11, KeyModifier.CTRL, handler) # works as expected
         Env.addHotkey(Key.F11, KEY_CTRL, handler) # works as expected too
         Env.addHotkey(Key.F11, Key.CTRL, handler) # fails

         # another example:

         Env.addHotkey(Key.F11, KeyModifier.WIN, handler) # doesn't fail but doesn't work as expected
         Env.addHotkey(Key.F11, KEY_WIN, handler) # works as expected
         Env.addHotkey(Key.F11, Key.WIN, handler) # fails

This needs to be standardized (an issue with obsolete constants). Also in removeHotkey function, I suppose.

#2.
         Env.addHotkey(Key.F12, 0, handler) # see below

This is passed but generally doen't work on Windows. The solution is to change system debugger hotkey in the registry: HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\UserDebuggerHotKey from 0 to any suitable value (0x2F for example), then reboot; this will turn off the debugger hotkey F12 and release this key to use as Sikuli hotkey.

Also SHIFT+F12 hotkey can't be set without registry tweaking. But CTRL+F12 can be successfully set, I did it on my Windows 7 machine.

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2016-12-09
Last query:
2016-12-09
Last reply:
2016-12-08
Best RaiMan (raimund-hocke) said : #1

thanks. made it a bug.

RaiMan (raimund-hocke) said : #2

a bug now

Alex Lunyov (lunyov-av) said : #3

Ok, RaiMan, I'll then check a new build.

Alex Lunyov (lunyov-av) said : #4

Thanks RaiMan, that solved my question.

Alex Lunyov (lunyov-av) said : #5

I have checked and now it works as described in the docs, thank you :)

RaiMan (raimund-hocke) said : #6

Thank YOU for finding this inconsistency.