Could not install Sikuli 1.1 Fatal Error 110: loading: winUtil.dll

Asked by Leslie Justus on 2014-05-05

Have already successfully loaded and used Sikuli 1.0.rc3 for over a year and then switched over to Sikuli 1.0.1 in the last few weeks. (Uninstalled Sikuli 1.0rc3, then installed Sikuli 1.0.1 in c:\SikuliX. All was fine. Today, renamed SikliX to SikuliX1.01. Created a new directory c:\Automation\Sikuli\1.1 and copied the sikulixsetup-1.1.jar to that folder and tried to install. This is on a WIN7 32-bit system that we run in a VM. We have been using Sikuli 1.0.rc3 for 18+ months in this environment with no problem. Now trying to test out Sikuli 1.1 Beta release but have an issue on install. It keeps saying LoadLib: Fatal Error 110: loading WinUti.dll. Here is the log from the install.

[debug (5/5/14 1:33:21 PM)] Debug: setLogFile: C:\Automation\Sikuli\1.1\SikuliX-1.1.0-Beta1-SetupLog.txt
[debug (5/5/14 1:33:21 PM)] RunSetup: Setup in: C:/Automation/Sikuli/1.1/ using: sikulixsetup-1.1.jar
[debug (5/5/14 1:33:21 PM)] RunSetup: SikuliX Setup Build: 1.1.0-Beta1 2014-05-05-18
[debug (5/5/14 1:33:26 PM)] RunSetup: RunningSystem: Windows 6.1
[debug (5/5/14 1:33:26 PM)] RunSetup: parent of jar/classes: C:/Automation/Sikuli/1.1/
[debug (5/5/14 1:33:26 PM)] RunSetup: RunningJava: Java 6 (x86) 1.6.0_29-b11
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="USER_TYPE" value="0"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="IDE_SESSION" value=""/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="CAPTURE_HOTKEY" value="50"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="CAPTURE_HOTKEY_MODIFIERS" value="3"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="CAPTURE_DELAY" value="1.0"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="STOP_HOTKEY" value="67"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="STOP_HOTKEY_MODIFIERS" value="9"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="EXPAND_TAB" value="true"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="TAB_WIDTH" value="4"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="FONT_SIZE" value="14"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="FONT_NAME" value="Monospaced"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="LOCALE" value="en_US"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="AUTO_NAMING" value="0"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="DEFAULT_THUMB_HEIGHT" value="50"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="PREF_MORE_COMMAND_BAR" value="1"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="AUTO_CAPTURE_FOR_CMD_BUTTONS" value="1"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="AT_SAVE_MAKE_HTML" value="true"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="AT_SAVE_CLEAN_BUNDLE" value="true"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="PREF_MORE_RUN_SAVE" value="false"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="PREF_MORE_HIGHLIGHT" value="false"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="CHECK_UPDATE" value="false"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="LAST_SEEN_UPDATE" value="0.0.0"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="LAST_CHECK_UPDATE" value="1399313661302"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="IDE_SIZE" value="0x0"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="IDE_LOCATION" value="0,0"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="PREF_MORE_IMAGES" value="false"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="PREF_MORE_IMAGES_PATH" value=""/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="PREF_MORE_MESSAGE" value="0"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="PREF_MORE_LOG_ACTIONS" value="true"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="PREF_MORE_LOG_INFO" value="true"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="CONSOLE_CSS" value="body { font-family:serif; font-size: 12px; }.normal{ color: black; }.debug { color:#505000; }.info { color: blue; }.log { color: #09806A; }.error { color: red; }"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="PREF_MORE_TEXT_SEARCH" value="false"/>
[debug (5/5/14 1:34:06 PM)] RunSetup: Prefs: <entry key="PREF_MORE_TEXT_OCR" value="false"/>
[debug (5/5/14 1:34:17 PM)] FileManager: Downloading 1.1.0-Beta1-1.jar having 6512 KB
[debug (5/5/14 1:34:24 PM)] FileManager: downloaded 6512 KB to C:\Automation\Sikuli\1.1\Downloads\1.1.0-Beta1-1.jar
[debug (5/5/14 1:34:24 PM)] FileManager: download time: 6
[debug (5/5/14 1:34:28 PM)] RunSetup: main: Copied from Downloads: 1.1.0-Beta1-1.jar
[debug (5/5/14 1:34:28 PM)] FileManager: Downloading 1.1.0-Beta1-4.jar having 15296 KB
[debug (5/5/14 1:35:01 PM)] FileManager: downloaded 15296 KB to C:\Automation\Sikuli\1.1\Downloads\1.1.0-Beta1-4.jar
[debug (5/5/14 1:35:01 PM)] FileManager: download time: 32
[debug (5/5/14 1:35:04 PM)] RunSetup: main: Copied from Downloads: 1.1.0-Beta1-4.jar
[debug (5/5/14 1:35:04 PM)] RunSetup: Download ended
[debug (5/5/14 1:35:04 PM)] RunSetup: Downloads for selected options:
1.1.0-Beta1-1.jar - 1.1.0-Beta1-4.jar -
[debug (5/5/14 1:35:04 PM)] RunSetup: Download page: https://launchpad.net/raiman/sikulix2013+/1.1.0
[debug (5/5/14 1:35:04 PM)] RunSetup: recreating IDE (exclude scripting support)
[debug (5/5/14 1:35:04 PM)] FileManager: buildJar: C:\Automation\Sikuli\1.1\sikuli-temp.jar
[debug (5/5/14 1:35:04 PM)] FileManager: buildJar: adding: C:\Automation\Sikuli\1.1\sikulix.jar
[debug (5/5/14 1:35:13 PM)] FileManager: buildJar: completed
[debug (5/5/14 1:35:13 PM)] RunSetup: adding needed stuff to sikulix.jar
[debug (5/5/14 1:35:13 PM)] FileManager: buildJar: C:\Automation\Sikuli\1.1\sikuli-temp.jar
[debug (5/5/14 1:35:13 PM)] FileManager: buildJar: adding: C:\Automation\Sikuli\1.1\sikulix.jar
[debug (5/5/14 1:35:20 PM)] FileManager: buildJar: adding: C:\Automation\Sikuli\1.1\sikulixsetup-1.1.jar
[debug (5/5/14 1:35:28 PM)] FileManager: buildJar: adding: C:\Automation\Sikuli\1.1\sikulijython.jar
[debug (5/5/14 1:35:47 PM)] FileManager: buildJar: completed
[debug (5/5/14 1:35:47 PM)] RunSetup: exporting commandfiles
[debug (5/5/14 1:35:47 PM)] ResourceLoader: export: Trying to access package for exporting: Commands/windows#runsikulix.cmd
to: C:/Automation/Sikuli/1.1/
[debug (5/5/14 1:35:47 PM)] ResourceLoader: export: from: file:/C:/Automation/Sikuli/1.1/sikulixsetup-1.1.jar
[debug (5/5/14 1:35:48 PM)] ResourceLoader: export: Found 1 Files in Commands/windows/runsikulix.cmd
[debug (5/5/14 1:35:50 PM)] RunSetup: trying to set up the environment
[debug (5/5/14 1:35:50 PM)] ResourceLoader: check: we are running on arch: x86
[debug (5/5/14 1:35:50 PM)] ResourceLoader: check: using Java at: C:/Program Files/Java/jre6/
[error (5/5/14 1:35:50 PM)] ResourceLoader: check: No valid libs path available until now!
[action (5/5/14 1:35:50 PM)] ResourceLoader: check: Please wait! Trying to extract libs to jar parent folder: C:/Automation/Sikuli/1.1/
[debug (5/5/14 1:35:50 PM)] ResourceLoader: extractLibs: from: file:/C:/Automation/Sikuli/1.1/sikulixsetup-1.1.jar
[debug (5/5/14 1:35:51 PM)] ResourceLoader: extractLibs: Found 20 Files in META-INF/libs/windows/libs32/
[debug (5/5/14 1:35:53 PM)] ResourceLoader: checkLibsDir: trying: C:\Automation\Sikuli\1.1\libs
[debug (5/5/14 1:35:53 PM)] ResourceLoader: checkLibsDir: Running on Windows - checking system path!
[debug (5/5/14 1:35:55 PM)] ResourceLoader: checkLibsDir: Added libs dir to path: C:\Automation\Sikuli\1.1\libs
[debug (5/5/14 1:35:55 PM)] ResourceLoader: checkLibsDir: ... n25;c:\support tools;C:\Automation\Sikuli\1.1\libs
[error (5/5/14 1:35:55 PM)] ResourceLoader: loadLib: Fatal Error 110: loading: WinUtil.dll
[error (5/5/14 1:35:55 PM)] ResourceLoader: loadLib: Since native library was found, it might be a problem with needed dependent libraries
C:\Automation\Sikuli\1.1\libs\WinUtil.dll: The specified procedure could not be found
[error (5/5/14 1:35:55 PM)] ResourceLoader: loadLib: Check, wether a valid Sikuli libs folder is in system path at runtime!
[error (5/5/14 1:35:55 PM)] ResourceLoader: loadLib: Running Setup: ignoring this error for now
[debug (5/5/14 1:35:55 PM)] ResourceLoader: checkLibsDir: Using libs at: C:\Automation\Sikuli\1.1\libs
[debug (5/5/14 1:35:55 PM)] ResourceLoader: check: recreated ClassLoader.usrPaths
[debug (5/5/14 1:35:58 PM)] RunSetup: Trying to run functional test: running script statements via SikuliScript
[debug (5/5/14 1:35:58 PM)] SikuliX: add to classpath: C:\Automation\Sikuli\1.1\sikulix.jar
[debug (5/5/14 1:35:58 PM)] RunSetup: trying to run a test using SikuliScript with Jython
[debug (5/5/14 1:36:01 PM)] JythonScriptRunner: init: python.path hack:
C:\Automation\Sikuli\1.1\sikulixsetup-1.1.jar\Lib
[debug (5/5/14 1:36:05 PM)] Jython: sikuli: __init__: entering
[debug (5/5/14 1:36:05 PM)] Jython: sikuli: Sikuli: entering
[debug (5/5/14 1:36:09 PM)] Jython: sikuli: Sikuli: constants
[debug (5/5/14 1:36:09 PM)] Jython: sikuli: Sikuli: import Region
[debug (5/5/14 1:36:09 PM)] Jython: sikuli: Sikuli: import Screen
[debug (5/5/14 1:36:09 PM)] Screen: initScreens: basic initialization (1 Screen(s) found)
[debug (5/5/14 1:36:09 PM)] Screen: *** monitor configuration (primary: 0) ***
[debug (5/5/14 1:36:09 PM)] Screen: 0: S(0)[0,0 1276x874]
[debug (5/5/14 1:36:09 PM)] Screen: *** end monitor configuration ***
[debug (5/5/14 1:36:09 PM)] Jython: sikuli: Sikuli: Env.addHotkey
[debug (5/5/14 1:36:09 PM)] Jython: sikuli: Sikuli: import Match
[debug (5/5/14 1:36:09 PM)] Jython: sikuli: Sikuli: import Pattern
[debug (5/5/14 1:36:09 PM)] Jython: sikuli: Sikuli: import Location
[debug (5/5/14 1:36:09 PM)] Jython: sikuli: Sikuli: import ScreenUnion
[debug (5/5/14 1:36:09 PM)] Jython: sikuli: Sikuli: import Finder
[debug (5/5/14 1:36:10 PM)] ResourceLoader: loadLib: Now loaded: VisionProxy from: C:\Automation\Sikuli\1.1\libs\VisionProxy.dll
[error (5/5/14 1:36:10 PM)] RunSetup: null
[error (5/5/14 1:36:10 PM)] RunSetup: Something serious happened! Sikuli not useable!
Check the error log at C:\Automation\Sikuli\1.1\SikuliX-1.1.0-Beta1-SetupLog.txt
[error (5/5/14 1:38:21 PM)] RunSetup: Functional test Jython did not work
[error (5/5/14 1:38:21 PM)] RunSetup: ... terminated abnormally :-(
[error (5/5/14 1:38:21 PM)] RunSetup: Something serious happened! Sikuli not useable!
Check the error log at C:\Automation\Sikuli\1.1\SikuliX-1.1.0-Beta1-SetupLog.txt

Even though it did not install correctly, I still tried to run Sikuli via the command line. I got this error:
[error] ResourceLoader: loadLib: Fatal Error 110: loading: WinUtil.dll
[error] ResourceLoader: loadLib: Since native library was found, it might be a problem with needed dependent libraries
C:\Automation\Sikuli\1.1\libs\WindUtil.dl: The specified procedure could not be found.
[error] ResourceLoader: loadIb: Check, wether a valid Sikuli libs folder is in system path at runtime!
[error] RunSetup: Problem with SikuliX libs folder - see error log

Can you help with this problem?

Provide an answer of your own, or ask Leslie Justus for more information if necessary.

To post a message you must log in.