impossible to install openCV 2.1 with fedora 17

Asked by sabulinuo nuo on 2013-07-22

Hi

I had to install really quickly sikuli and use it in a java code with fedora 17 environnment

I couldn't I had to correct code source of library openCV 2.1 and it still doesnt work
the command make stops at 70% impossible to correct again code source the bug is directly located in a so library :@@@

Had someone managed to install it? is there another working version of OpenCV usable for sikuli? 2.4 and 2.2 didn't work ...

I still have this error java.lang.UnsatisfiedLinkError: /tmp/tmplib/libVisionProxy.so: libml.so.2.1: cannot open shared object file: No such file or directory

It s really desperate I already had to give up another testing framework because it couldn't support chromium browser

Question information

Language:
Franco-Proven├žal Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
sabulinuo nuo
Solved:
2013-07-23
Last query:
2013-07-23
Last reply:
2013-07-22
RaiMan (raimund-hocke) said : #1

What version? RC3 or 1.0.0 ?

sabulinuo nuo (sabulinuo) said : #2

Actually I downloaded this version of sikuli: sikuli-r931-linux-i686.zip

sabulinuo nuo (sabulinuo) said : #3

If I try to install this package via yum opencv-2.1.0-6.fc14.i686.rpm the error still occurs
and the build of sources isn't working

sabulinuo nuo (sabulinuo) said : #4

finally it seems to work with :
opencv-2.1.0-6.fc14.i686.rpm
and cp libtiff.so.3.9.7 libtiff.so.4 in /usr/lib
and sudo ln -s /usr/lib/libtiff.so4 libtiff.so4 in /lib

and with all devel packages libjpeg, libtiff, libjasper, libpng and zlib

sabulinuo nuo (sabulinuo) said : #5

After linux fedora update, it doesn't work again .... the only solution is to give up sikuli for this environment and find another tool not using opencv