How I can copy file url after uploading image into ftp server?

Asked by faiwer on 2015-09-21

Hello. I'm using my FTP server for my screenshots. When I was used dropbox, I was can copy image-dropbox-url after upload. But now I'm using FTP. And after uploading I was see only nofify-message in bottom-right corner of screen. Don't see any dialogs with links. Public links submenu also empty.

Images uploaded normally. Using passive ftp mode.
settings: http://ftp.faiwer.ru/img_21_09_23:51:01_e6d4447b8a6.png

Question information

Language:
English Edit question
Status:
Solved
For:
Shutter Edit question
Assignee:
No assignee Edit question
Solved by:
faiwer
Solved:
2015-10-02
Last query:
2015-10-02
Last reply:
Varrcan (vitar07) said : #1

My settings:
http://varrcan.me/upload/01102015005.png
http://varrcan.me/upload/01102015006.png

After you create a screenshot press "upload". You will notice that the file has been successfully uploaded (with a local link). A link to the server will be copied to the clipboard.
Public links with the FTP upload will not be created.
------
ЗЫ Я тоже долго боролся с этим. С такими настройками как у меня все работает замечательно. После создания скриншота нажми "выгрузить". Появится уведомление о том, что файл успешно выгрузился (с локальной ссылкой). Ссылка на сервер автоматически скопируется в буфер. Публичные ссылки при выгрузке на FTP не создаются.

faiwer (faiwer) said : #2

Varrcan, I think you dont understood me. I want to copy HTTP-link to uploaded image (^http://ftp.faiwer.ru/...). After upload to dropbox or other services I can copy public-link. After uploading to FTP - can't. I tried this option (from your screenshot). It option only copy local filename (in OS) into clipboard. And copied it after screenshot has been created.
----
Какой же кривой у меня английский однако... Написал на случай если кто ещё подключиться. Ты меня кажется не понял. Галочка, что ты указал, приводит к тому, что, после создания скриншота, путь к нему в ОС будет скопирован в буфер. Т.е. /home/faiwer/... А я же хочу, чтобы как с dropbox-ом было. После аплоада файла на FTP мне предлагалась ссылка до файла по HTTP (там даже опция в диалоге для этого есть).

Выставив эту опцию, что ты показал, у меня после создания скриншота путь до файла в ОС копироваться стал в буфер. И больше ничего не произошло. Как впрочем и должно было бы быть, если я правильно понимаю суть этой опции. Может быть я тебя не правильно понял? Меня интересует http://ftp.faiwer.ru/%блабла%. Вот эти две ссылки в твоём прошлом ответе ты вручную сформировал или они у тебя в буфер скопировались в таком виде сразу (http://varrcan.me/...)?

faiwer (faiwer) said : #3

Now I'm do that:

1. upload to FTP by Shutter FTP dialog
2. copy local filename of file by context menu of image in main shutter window
3. run that ( https://gist.github.com/faiwer/9847245ed2f4c869b956 )

Varrcan (vitar07) said : #4

Мои шаги:
1 Делаю скриншот (редактирую, сохраняю)
2 Нажимаю "Экспорт"
3 Открывается окно с настройками выгрузки. Нажимаю "Выгрузить"
4 Ниже отображается прогресс-бар, что идет загрузка на сервер ftp
5 Справа внизу отображается уведомление, файл загружен и указана ссылка на локальный файл
6 При этом ссылка на сервер вида http://varrca...... автоматически копируется в буфер.

Как я понял, она копируется в том случае, если были правильно указаны настройки ftp. Изначально у меня вообще ничего не работало, только сохранялся локальный файл. Методом тыка добился выгрузки на ftp и http-ссылка при этом начала автоматом копироваться в буфер. Но позже ставил эту программу на другой комп. При этом выгрузка на сервер шла, но в буфер копировался локальный путь. Открыл настройки со своего компьютера, перенес их на другой и все нормально заработало :)

Примечание: у моего пользователя FTP домашняя дирректория указана ../www/varrcan.me/upload , поэтому у меня в первом поле только адрес сайта, без дирректорий.

Попробуй в первом поле изменить ссылку на: "faiwer.ru/srv/ftp/screenshots/", нижнее без изменений. Если не поможет, почему бы не попробовать как у меня - назначить твоему пользователю ftp домашнюю дирректорию srv/ftp/screenshots и в первом поле программы указать только домен faiwer.ru
А вдруг сработает. Мало ли, может программа не понимает папки. Я до конца так и не уловил логику её работы :)

google-translate, sorry :)
---------

My steps:
1 to take screenshots (edit, save)
2 Press the "Export"
3 The window with the settings of discharge. Press "Unload"
4 below shows the progress bar that the loading on the ftp server
5 bottom right notification is displayed, the file is loaded and contains a link to a local file
6 The link to the server type http: // varrca ...... is automatically copied to the clipboard.

As I understand it, it is copied into the case were correctly specified settings ftp. Initially, I did not work at all, lasted only a local file. At random on the discharge has made ftp and http-link at the beginning of this machine copied to the clipboard. But later I put this program on another computer. At the same time the server was unloaded, but copied to the clipboard local path. He opened the settings from your computer, transfer them to the other and all work properly :)

Note: my FTP user home within a directory contains ../www/varrcan.me/upload, so I have only the first field site address without within a directory.

Try it in the first field, the reference to: "faiwer.ru/srv/ftp/screenshots/", bottom unchanged. If you do not help, why not try it as I have - assign your user ftp home within a directory srv / ftp / screenshots in the first field of the program to specify only the domain faiwer.ru
And suddenly it works. Who knows, you can not understand the program folder. I'm up to the end and did not catch the logic of her work :)

faiwer (faiwer) said : #5

В общем разобрался. Дело в: "Can't call method "append_file_name" on an undefined value at /usr/bin/shutter line 10742". Там попытка вызвать Gnome2::VFS::URI->new( $ftp_wurl_entry_dlg->get_text )->append_file_name

Видимо из-за LinuxMint-а, там должен быть не Gnome2 а Mate или что-нибудь в таком духе. В общем метод недоступен. Влепил туда вручную конкатенацию строками (perl) - всё заработало. Пожалуй зарегаю им багу

Varrcan (vitar07) said : #6

Глубоко копнул ))
У меня на Linux Mint Cinnamon работает без ошибок

Vladislav (vlad7rpk) said : #8

Just install a dependency: libgnomevfs2-extra