How to show reason for new upload plugin failure to load?

Asked by Marco van Hilst on 2014-07-25

I was wondering if there was an easy way to have Shutter show more info about an inability to load an upload plugin.

At the moment it only prints 'ERROR: upload-plugin exists but is not executable - <path to plugin>' while loading with --clear_cache and --debug.

Given that I am relatively new to Perl, I feel like I'm taking shots in the dark to figure out why it won't load. (I've ruled out syntax errors as a reason so far, but the rest I can't test without an instance of Shutter to actually load and execute the plugin.)

Question information

Language:
English Edit question
Status:
Solved
For:
Shutter Edit question
Assignee:
No assignee Edit question
Solved by:
Marco van Hilst
Solved:
2014-07-25
Last query:
2014-07-25
Last reply:
Marco van Hilst (axiometry) said : #1

(On a side note...) There was a mention that Shutter could load plugins from ~/.shutter/plugins/{bash,perl} (https://answers.launchpad.net/shutter/+question/118974). Does this only apply to imge plugins? It doesn't seem to work for upload plugins.

Marco van Hilst (axiometry) said : #2

Oh... I solved it! 'Not executable' quite literally meant not executable! chmod +x and it was fixed!

Marco van Hilst (axiometry) said : #3

I fixed the Dropbox plugin, switching libs to WebService::Dropbox from Net::Dropbox::API and using the /media Dropbox API now that public folders have been discontinued. Saves files to Apps/Shutter. http://hastebin.com/kirorocowu.pm

Hi Marco,

I have merged your request a few minutes ago. Good work - keep it up. Interested in creating a Google Drive plugin? ;)

Kind regards
Mario

Marco van Hilst (axiometry) said : #5

Will do! Perl is neat-o