shutter won't start in ubuntu 10.04

Asked by hasi weragala on 2010-08-25

Hi. My System is Ubuntu 10.04 (Kernel 2.6.35) and I use "Equinox" theme(gnome). Problem is Shutter doesn't start. Terminal output is as follows.

----------------------------------------------------------------------------------------------------

hasi@hasi-desktop:~$ shutter --debug

Gtk-Message **: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory at /usr/lib/perl5/Gtk2.pm line 138.
WARNING: Net::DBus::GLib is missing --> Ubuntu One support will be disabled!

Gtk-WARNING **: Unable to locate theme engine in module_path: "equinox", at /usr/bin/shutter line 192.
Gtk-WARNING **: Unable to locate theme engine in module_path: "equinox", at /usr/bin/shutter line 192.
Gtk-WARNING **: Unable to locate theme engine in module_path: "equinox", at /usr/bin/shutter line 192.
Gtk-WARNING **: Unable to locate theme engine in module_path: "equinox", at /usr/bin/shutter line 192.
INFO: command debug recognized!

INFO: gathering system information...

Linux hasi-desktop 2.6.35-020635-generic #020635 SMP Mon Aug 2 10:16:00 UTC 2010 i686 GNU/Linux

Ubuntu 10.04.1 LTS \n \l

Glib 1.222
Gtk2 1.221

Glib built for 2.22.2, running with 2.24.0
Gtk2 built for 2.20.0, running with 2.20.0

Unrecognized image file format at /usr/bin/shutter line 7411.

---------------------------------------------------------------------------------------------------------------------------

libcanberra-gtk-module exists in the system. please help..

Question information

Language:
English Edit question
Status:
Answered
For:
Shutter Edit question
Assignee:
No assignee Edit question
Last query:
2010-08-25
Last reply:
2012-12-12

  Other Gtk applications, e.g. gedit, work?

  Please check that librsvg is installed on your system (e.g. via synaptic).

hasi weragala (wkhasintha) said : #3

@Mario : Other applications work fine sir.

'librsvg2.2' and 'librsvg2-common' are already installed on the system.

Are you able to open a svg file with gnome's image viewer (eye of gnome)?

hasi weragala (wkhasintha) said : #5

Yes , I can open svg files using eye of gnome.

In addition sir I have KDE installed and tried to run it on KDE but It still doesn't start. :(

  Can you please launch 'gdk-pixbuf-query-loaders' via terminal and
attach the output here?

hasi weragala (wkhasintha) said : #7

------------------------------------------------------------------------

# GdkPixbuf Image Loader Modules file
# Automatically generated file, do not edit
# Created by gdk-pixbuf-query-loaders from gtk+-2.20.0
#
# LoaderDir = /usr/local/lib/gtk-2.0/2.10.0/loaders
#
"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-gif.so"
"gif" 4 "gtk20" "The GIF image format" "LGPL"
"image/gif" ""
"gif" ""
"GIF8" "" 100

"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-bmp.so"
"bmp" 5 "gtk20" "The BMP image format" "LGPL"
"image/bmp" "image/x-bmp" "image/x-MS-bmp" ""
"bmp" ""
"BM" "" 100

"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-tga.so"
"tga" 4 "gtk20" "The Targa image format" "LGPL"
"image/x-tga" ""
"tga" "targa" ""
" \001\001" "x " 100
" \001\t" "x " 100
" \002" "xz " 99
" \003" "xz " 100
" \n" "xz " 100
" \013" "xz " 100

"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-icns.so"
"icns" 4 "gtk20" "The ICNS image format" "GPL"
"image/x-icns" ""
"icns" ""
"icns" "" 100

"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-pnm.so"
"pnm" 4 "gtk20" "The PNM/PBM/PGM/PPM image format family" "LGPL"
"image/x-portable-anymap" "image/x-portable-bitmap" "image/x-portable-graymap" "image/x-portable-pixmap" ""
"pnm" "pbm" "pgm" "ppm" ""
"P1" "" 100
"P2" "" 100
"P3" "" 100
"P4" "" 100
"P5" "" 100
"P6" "" 100

"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xpm.so"
"xpm" 4 "gtk20" "The XPM image format" "LGPL"
"image/x-xpixmap" ""
"xpm" ""
"/* XPM */" "" 100

"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-jpeg.so"
"jpeg" 5 "gtk20" "The JPEG image format" "LGPL"
"image/jpeg" ""
"jpeg" "jpe" "jpg" ""
"\377\330" "" 100

"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so"
"png" 5 "gtk20" "The PNG image format" "LGPL"
"image/png" ""
"png" ""
"\211PNG\r\n\032\n" "" 100

"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-ico.so"
"ico" 5 "gtk20" "The ICO image format" "LGPL"
"image/x-icon" "image/x-ico" "image/x-win-bitmap" ""
"ico" "cur" ""
" \001 " "zz znz" 100
" \002 " "zz znz" 100

"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-wbmp.so"
"wbmp" 4 "gtk20" "The WBMP image format" "LGPL"
"image/vnd.wap.wbmp" ""
"wbmp" ""
" " "zz" 1
" `" "z " 1
" @" "z " 1
" " "z " 1

"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-ani.so"
"ani" 4 "gtk20" "The ANI image format" "LGPL"
"application/x-navi-animation" ""
"ani" ""
"RIFF ACON" " xxxx " 100

"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-pcx.so"
"pcx" 4 "gtk20" "The PCX image format" "LGPL"
"image/x-pcx" ""
"pcx" ""
"\n \001" "" 100
"\n\002\001" "" 100
"\n\003\001" "" 100
"\n\004\001" "" 100
"\n\005\001" "" 100

"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xbm.so"
"xbm" 4 "gtk20" "The XBM image format" "LGPL"
"image/x-xbitmap" ""
"xbm" ""
"#define " "" 100
"/*" "" 50

"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-ras.so"
"ras" 4 "gtk20" "The Sun raster image format" "LGPL"
"image/x-cmu-raster" "image/x-sun-raster" ""
"ras" ""
"Y\246j\225" "" 100

"/usr/local/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-qtif.so"
"qtif" 4 "gtk20" "The QTIF image format" "LGPL"
"image/x-quicktime" "image/qtif" ""
"qtif" "qif" ""
"abcdidsc" "xxxx " 100
"abcdidat" "xxxx " 100

------------------------------------------------------------------------

  Obviously there is no svg support. I am wondering why your loader
directory is
/usr/local/lib/gtk-2.0/2.10.0/loaders.

Mine is /usr/lib/gtk-2.0/2.10.0/loaders...

Julianloui (julianloui) said : #9

I have the same problem with my Ubuntu 11 .04 band Ubuntu 12.04 systems. I have no trouble in opening Shutter via the GUI.
When I enter on the command line

@Julianloui: What specific problem do you have?

Can you help with this problem?

Provide an answer of your own, or ask hasi weragala for more information if necessary.

To post a message you must log in.