I can not run SST on Ubuntu 10.04

Asked by Ayo on 2013-11-08

Hi All,

I just installed a new Ubuntu 10.04 and I am trying to install SST on it.
I installed it using these commands
    $ sudo apt-get install python-pip xvfb
    $ sudo pip install -U sst
and got successful installation result.

But when I ran a simple test, I got this error

pamies@Simba:~$ sst-run mytest
Traceback (most recent call last):
  File "/usr/local/bin/sst-run", line 9, in <module>
    load_entry_point('sst==0.2.4', 'console_scripts', 'sst-run')()
  File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 299, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 2229, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 1948, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/local/lib/python2.6/dist-packages/sst/scripts/run.py", line 29, in <module>
    from sst import (
  File "/usr/local/lib/python2.6/dist-packages/sst/runtests.py", line 27, in <module>
    from sst import (
  File "/usr/local/lib/python2.6/dist-packages/sst/loaders.py", line 26, in <module>
    import unittest.loader
ImportError: No module named loader

I would be grateful for any tips and pointers to resolve this problem.
Thanks in advance,

BR Ayo.

Question information

Language:
English Edit question
Status:
Solved
For:
selenium-simple-test Edit question
Assignee:
No assignee Edit question
Solved by:
Corey Goldberg
Solved:
2013-12-18
Last query:
2013-12-18
Last reply:
2013-11-08
Vincent Ladeuil (vila) said : #1

sst relies on python's unittest being recent enough.

$ rmadison python
    python | 2.6.5-0ubuntu1 | lucid | all
    python | 2.6.5-0ubuntu1.1 | lucid-updates | all
    python | 2.7.3-0ubuntu2 | precise | amd64, armel, armhf, i386, powerpc
    python | 2.7.3-0ubuntu2.2 | precise-updates | amd64, armel, armhf, i386, powerpc
    python | 2.7.3-0ubuntu7 | quantal | amd64, armel, armhf, i386, powerpc
    python | 2.7.3-0ubuntu7.1 | quantal-updates | amd64, armel, armhf, i386, powerpc
    python | 2.7.4-0ubuntu1 | raring | amd64, armhf, i386, powerpc
    python | 2.7.5-5ubuntu1 | saucy | amd64, arm64, armhf, i386, powerpc
    python | 2.7.5-5ubuntu1 | trusty | amd64, arm64, armhf, i386, powerpc

10.04 (lucid) carries 2.6.5, I don't remember when unittest.loader was introduced in python but you should probably upgrade to precise (12.04) in any case.

If you can't do that, you'll need to find a more recent python and install that (which may have undesired fallouts...).

Best Corey Goldberg (coreygoldberg) said : #2

SST requires Python 2.7.

if you *really* need to run on 10.04, you can build Python 2.7 yourself and run SST with that interpreter. An easier solution would be to upgrade to a more modern Ubuntu release.

Ayo (k-akolay1) said : #3

Thanks Corey Goldberg, that solved my question.