SST install from Video on Ubuntu12 not working -- failed with has no attribute extended_traceback

Asked by R. Morgan on 2012-08-11

I just install SST on my Ubuntu 12.04 machine (an upgrade from 11.10) and can't seem to successfully run the mytest program given in the video. So I pulled the project and installed the dev files and ran sst-run --text. I recieved the output below. Does anyone have any ideas on how to solve this?

starting SST...
----------------------------------------------------------------------
waiting for django to come up...
django found. continuing...

  date time: 2012-08-11 13:30
  test directory: 'selftests'
  report format: 'console'
  browser type: 'Firefox'
  javascript disabled: False
  browswermob proxy launcher: None
  shared directory: None
  screenshots on error: False
  failfast: False
  debug: False
  headless xserver: False

Traceback (most recent call last):
  File "./sst-run", line 190, in <module>
    main()
  File "./sst-run", line 94, in main
    extended=cmd_opts.extended_tracebacks,
AttributeError: Values instance has no attribute 'extended_tracebacks'

Question information

Language:
English Edit question
Status:
Answered
For:
selenium-simple-test Edit question
Assignee:
No assignee Edit question
Last query:
2012-08-11
Last reply:
2012-08-14
Corey Goldberg (coreygoldberg) said : #1

to run the dev version, make sure you have the PyPI version totally uninstalled. (pip uninstall leaves the sst-run scripts. etc)

Can you help with this problem?

Provide an answer of your own, or ask R. Morgan for more information if necessary.

To post a message you must log in.