Can't find the User Guide

Asked by TheOldFellow on 2012-12-10

I installed Scribes under Mint 14 Cinnamon from it's repository (0.4-dev-build910).
When I press F1 I get the browser with Mint's help page :(.
When I bring up the Keyboard shortcuts and click the 'show user guide' in the top right, I get the Mint help page :(
The website doesn't have the User Guide in the documentation page. :(

I am assuming that there isn't, in fact, a user guide. Correct? Or is the Mint version bust?
It would be REAL helpful to put a copy on the website.

But I love the editor, and no one is going to take it away from me!

Thx. TOF

Question information

Language:
English Edit question
Status:
Solved
For:
Scribes Edit question
Assignee:
No assignee Edit question
Solved by:
TheOldFellow
Solved:
2012-12-10
Last query:
2012-12-10
Last reply:
TheOldFellow (theoldfellow) said : #1

Just to say I now have the latest version build1052, and it exhibits the same behaviour.

I'm a bit worried that there has been no updates for over a year, althouth you are answering some questions....

TOF

Mystilleef (mystilleef) said : #2

Make sure you have Yelp installed. Ctrl+h also shows you many of the functions available in Scribes.

There has been no update because I need to port Scribes to Python 3 and GNOME 3. Which means I'll be rewriting Scribes. So the current version of Scribes has reached its end of life.

Unfortunately, I don't have any time for the project at the moment. I have a business to run and bills to pay. :-D

However, once real life work loads abate, I'll breathe new life into the Scribes. :-)

TheOldFellow (theoldfellow) said : #3

Thanks for the very quick reply - proves Scribes is still very active. I think you mean 'end of development', not 'end of life'.

I have been using it for a few months (ruby and web), but decided to really try and get the most out of it today. I already had yelp installed.

I have to warn you that real life never gets easier. I retired 10 years ago, and I work longer hours than when I was deputy CTO... - I just don't get paid :)

It's from the Ctrl+h screen that I am trying to get the User Guide (top right). Perhaps I am reading this wrong, and Ctrl-h IS the user guide and the legend in the top right is just a title?

TOF.

Mystilleef (mystilleef) said : #4

I hear you. Even though I have plans to retire some day. I have no plans to retire from programming. :-)

Launch Scribes from the command line and see if you get any error messages when you press F1.

Ctrl+H is not the user guide. It just shows a list of keyboard shortcuts.

The user guide is launched in a help browser called Yelp.

TheOldFellow (theoldfellow) said : #5

Thanks. I have worked it out. Something had installed another yelp in /usr/local/bin, which was nearer the start of the PATH, it must be a MINT 'feature'. Anyway, removed that, reinstalled yelp and scribes, and everything now works.

The law of unintended consequences.... I'll berate the Mint guys.

TOF.

TheOldFellow (theoldfellow) said : #6

Just to tie up the loose ends. Linux Mint installs a package ubuntu-system-adjustments, this installs /usr/local/bin/yelp and that stops applications calling yelp (unless they call /usr/bin/yelp). The recommended solution for Scribes users is to take the execute bit off it, this restores normal yelp behaviour. The Mint guys are aware their solution is a bit 'hit and miss'.

Thanks for the wonderful support,
TOF