Scribes compiles fine, but cannot save files

Asked by leeand00 on 2012-04-20

I get this error when trying to save files in scribe:

Traceback (most recent call last):
  File "/usr/local/scribes/lib/python2.6/site-packages/SCRIBES/SaveSystem/DbusDataSender.py", line 34, in __send
    self.__processor.process(
AttributeError: 'NoneType' object has no attribute 'process'

scribes-0.4-dev-build954

Question information

Language:
English Edit question
Status:
Solved
For:
Scribes Edit question
Assignee:
No assignee Edit question
Solved by:
leeand00
Solved:
2012-04-21
Last query:
2012-04-21
Last reply:
Mystilleef (mystilleef) said : #1

Can you install scribes following the instructions in the link provided below and try again? Make sure you kill all running instances of Scribes and remove Scribes completely from your system before installing.

http://mystilleef.blogspot.com/2010/10/scribes-gets-ubuntu-ppa.html

Mystilleef (mystilleef) said : #2

Oh, I assumed you are using Ubuntu, if not let me know.

leeand00 (leeand00) said : #3

Yup, I'm using Ubuntu, (but it's a bit of an old version of Ubuntu..10.04 LTS, but that's what Long Term Service is all about...)

Okay, I removed it using "sudo apt-get remove scribes"

And deleted the binaries from the source version I compiled....I'm off to try out the PPA.

leeand00 (leeand00) said : #4

I installed the PPA and scribes (using Synaptic Package Manager, just to make sure the PPA was being used).

Now that I've installed it I get an error which reads:

"RuntimeError: could not create GladeXML object."

I looked up GladeXML in apt-cache and the only think that comes up are Perl libraries of some sort...no python libs...

Mystilleef (mystilleef) said : #5

Do you have libglade installed?

leeand00 (leeand00) said : #6

Well lets see...here are the ones I have installed:

libglade2-0
libglade2.0-cli
libglade2.0-cli-dev
libglademm-2.4-1c2a

there are seveal other libglade-type packages listed but not installed.

Mystilleef (mystilleef) said : #7

There might be a conflict between glade and gtkbuilder on your system.

Can you provide the details of

scribes -i

leeand00 (leeand00) said : #8

========================================================
System Info: ('Linux', 'U101', '2.6.32-40-generic', '#87-Ubuntu SMP Mon Mar 5 20:26:31 UTC 2012', 'i686')
Python Version: 2.6.5 (r265:79063, Apr 16 2010, 13:09:56)
[GCC 4.4.3]
System Byteorder: little
Python Modules: ('__builtin__', '__main__', '_ast', '_bisect', '_codecs', '_collections', '_functools', '_hashlib', '_locale', '_random', '_socket', '_sre', '_ssl', '_struct', '_symtable', '_warnings', '_weakref', 'array', 'binascii', 'cPickle', 'cStringIO', 'errno', 'exceptions', 'fcntl', 'gc', 'grp', 'imp', 'itertools', 'marshal', 'math', 'operator', 'posix', 'pwd', 'select', 'signal', 'spwd', 'strop', 'sys', 'syslog', 'thread', 'time', 'unicodedata', 'xxsubtype', 'zipimport', 'zlib')
========================================================
Scribes Version: 0.4-dev-build1052
Dbus Version: (0, 83, 0)
GTK+ Version: (2, 20, 1)
PyGTK Version: (2, 17, 0)
Psyco Version: (1, 6, 0, 'final', 0)
========================================================
Running Instance: 1
========================================================
Python Path: /usr/lib/python2.6/dist-packages
Plugin Path: /usr/lib/scribes/GenericPlugins
Data Path: /usr/share/scribes
Executable Path: /usr/bin
========================================================

I saw that it mentioned Psyco, and that it was missing so I installed it (it said it was a python compiler).

Mystilleef (mystilleef) said : #9

It seems you have 1 running instance of Scribes can you kill it. And start scribes again.

pkill scribes
killall scribes

scribes

See if you still get the same error.

leeand00 (leeand00) said : #10

No error and we are up and running! Thank you for your software and your dilligence Mystilleef!

Mystilleef (mystilleef) said : #11

Thanks for the donation. :-)

leeand00 (leeand00) said : #12

Sure thing! So it was so low...I'm unemployed at the moment, but your software has been helping me alot on my un-paid internship! There are alot of things I have to do on it and having an editor that doesn't distract me so much really does help me get things done!

Mystilleef (mystilleef) said : #13

Much appreciated. I'm glad you find Scribes useful.