Consistent indentation

Asked by Thomas Kluyver on 2011-06-17

Scribes offers options to change tabs to spaces, or vice versa, in the existing text. But after switching to spaces, new indentation it inserts will still be tabs. Also, when I open an existing (Python) file that uses spaces for indentation, Scribes will indent new lines I add with tabs.

Is there a way to configure the default indentation method? Or, better, could we have a 'sticky' indentation, so that when you replace tabs with spaces (or open a file which uses spaces), it remembers that and will use spaces on new lines.

Question information

Language:
English Edit question
Status:
Solved
For:
Scribes Edit question
Assignee:
No assignee Edit question
Solved by:
Thomas Kluyver
Solved:
2011-06-17
Last query:
2011-06-17
Last reply:
Mystilleef (mystilleef) said : #1

You can enable using spaces instead of tabs instead of tabs in the preferences window. Press F12 to show the preferences window.

Thomas Kluyver (takluyver) said : #2

Thanks for the quick reply - I hadn't found the preferences window.