Auto-save

Asked by Giulio Collura on 2011-02-18

Congratulations for this wonderful text editor, I really like it. There is only one feature I don't like so much, autosave. Is there a way to disable it? I did not have found inside preferences windows any option...

Thanks for all your time,
Giulio Collura

Question information

Language:
English Edit question
Status:
Solved
For:
Scribes Edit question
Assignee:
No assignee Edit question
Solved by:
Giulio Collura
Solved:
2011-02-18
Last query:
2011-02-18
Last reply:
Mystilleef (mystilleef) said : #1

Thanks for the feedback. There's no way to disable it. The premise of Scribes was designed and baked in automation and making sure the document is always saved.

Giulio Collura (gcollura) said : #2

Ok. Anyway if one day you will implement this feature, it will be surely well-accepted :)

Thanks again,
Giulio

Mystilleef (mystilleef) said : #3

There's a patch in launchpad bugs to disable it if you want. I don't recommend it.

tarpan (arpanek) said : #4

This single feature keeps me from using Scribes - otherwise a very good editor.

Regards,
Tarpan

Strider (alex-rayu) said : #5

Can you imagine it - you are working in Scribes on a PHP file on ftp, and it does dozens of saves as you are working on it, causing syntax errors on the live site until you have finished the while script. You can't just wait till you finish and THEN. That makes it virtually unusable for serious work.

porter (78536-b) said : #6

The following seems to work, although I have not fully tested it yet (use at your own risk). Edit /usr/lib/python2.7/site-packages/SCRIBES/SaveSystem/Manager.py and comment out the following lines:

from AutomaticSaver import Saver
Saver(self, editor)
from FocusOutSaver import Saver
Saver(self, editor)
from QuitSaver import Saver
Saver(self, editor)

py2maker (py2maker) said : #7

tarpan: This single feature keeps me from using Scribes - otherwise a very good editor.

Me too.

Regards,
py2maker