screenlets hide on show desktop

Asked by Tiede on 2008-05-22

Since screenlets are now available without compiz, I have decided to start using them (can't make compiz work with my Sis Graphics card)
I am aware of the fact that in compiz, there is a "show desktop" plugin that would make screenlets not hide on showdesktop, among other such options such as 'Skip Task bar', having a widget layer and using F9, and so on and so forth.
My problem is that these are compiz-specific options. I was wondering if any body has a work-around to make the screenlets not hide on a normal desktop without compiz enabled?
i.e, on a desktop without compiz, (GNOME), I click on the show desktop icon.
Expected behavior: Desktop is shown with widgets on it (à la gdesklets)
Current behavior: My screenlets disappear.

 --Note that I have said work-around and not fix, since I am aware that this is a current bug (in launchpad if I am not wrong) and that a proper fix is not available yet.
Also note that right-clicking a screenlet and choosing Window->Widget does not do anything. (inasmuch as if does not make said screenlet stop disappearing as expected).
Thanks for any insight provided hereafter.

Question information

Language:
English Edit question
Status:
Answered
For:
Screenlets Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Helder Fraga (whise) said :
#1

i already answerd you , however i hope you find a solution to

Revision history for this message
Tiede (marcarthur) said :
#2

My bad, I didn't get to your post under the bug report.

Well, at least I now know the 'why' of the problem...
Anyways, referring to your observation about WINDOW_TYPE_HINT_DOCK, since I am only looking for a workaround (as I previously mentioned), I wouldn't mind it if drag/move was disabled after setting the screenlets as such. i.e, I can just move everything where I want, and then apply said attribute...
(obviously, I don't really know what I am talking about, and maybe I am getting the whole "will break drag and move" sentence completely wrong).
But just in case I am not, how do I go about setting that attribute to my screenlets? And can it be done globally?
Thanks again.

Revision history for this message
Helder Fraga (whise) said :
#3

opein __init__.py

change
self.window.set_type_hint(gtk.gdk.WINDOW_TYPE_HINT_TOOLBAR)

to

self.window.set_type_hint(gtk.gdk.WINDOW_TYPE_HINT_DOCK)

save and install :)

Revision history for this message
Fabio Marzocca (thesaltydog) said :
#4

which is the file to be edited for this workaround?

Revision history for this message
fabioxxxx (fabioxxxx) said :
#5

Ubuntu Hardy

vi /usr/lib/python2.5/site-packages/screenlets/__init__.py
change to line :614 and uncomment
#self.window.set_type_hint(gtk.gdk.WINDOW_TYPE_HINT_DOCK)

restart screenlets

can't find it ? you can try
locate screenlet | grep screenlets/__init__.py
a freesh install of screenlet may require a updatedb

Thanks for the workaround guys , finally ... goodbye gdesklets XD
This should be in the screenlets FAQ

Can you help with this problem?

Provide an answer of your own, or ask Tiede for more information if necessary.

To post a message you must log in.