Problem importing sections

Asked by Brian Lockwood on 2008-07-10

I have used a csv to try and import some sections, here is part of the csv. The IDs are the ids of the persons which are in the system.
The error I get is

failed to import CSV text
The term Autumn does not exist.
The timetable schema 2008_01 does not exist.

The term Autumn does exist as does 2008_01 Schema

"Autumn","2008_01"
"","",""
"7NH/En","HY"
"Monday1","Lesson3"
"Thursday1","Lesson5"
"Thursday2","Lesson5"
"Wednesday2","Lesson1"
"***"
"E808204200052"
"G808300400029"
"R835200200028"
"V808207999028"
"Z808207600013"
"V808208000005"
"V808205900019"
"U808208000014"
"V808331501014"
"H808202200017"
"X808205000005"
"K808202200001"
"L875364700009"
"G808208400016"
"Y808202200011"
"N808205700018"
"C808205700019"
"C808204200012"
"M808236200068"
"C808208000002"
"Y807233600043"
"N808207999024"
"J808205000024"
"E808205000002"
"V808202200007"
"R806231300044"
"K808205000044"
"T808208799054"

Question information

Language:
English Edit question
Status:
Solved
For:
SchoolTool Edit question
Assignee:
No assignee Edit question
Solved by:
Brian Lockwood
Solved:
2008-07-13
Last query:
2008-07-13
Last reply:
2008-07-12
Brian Lockwood (brianlockwood) said : #1

Helloooooooooo, anyone there?

Actually, a bit of succes today but I stll can't do the import above. Manually entered a group and am sorting out the difference between courses and sections.

Running on ubunto 64bit under VMware and it goes like a rocket. V impressive.

Brian Lockwood (brianlockwood) said : #2

I have had some success but I found that I if I added another timetable and course to match a new import. It worked but I do think I was right before.
Discussion and pointers welcome.

Tom Hoffman (tom-hoffman) said : #3

Hi Brian,

Sorry we seem to have missed this question the first time around.

I suspect you need to create the term and timetable first before importing the sections.

This might be helpful in that regard:

http://schooltool.pov.lt/docs/individual.html

Brian Lockwood (brianlockwood) said : #4

I did create the timetable and term first. However, in the pursuit of trying to ecreate the problem, I have deleted everything and am starting again.
Group Import would be helped if you could nominate the members of the group in the import csv.
Person import would be helped by the ability to import far more fields than just login name, password first name and surname.

Brian Lockwood (brianlockwood) said : #5

One discovery is that the csv file that I was using on a mac was mac-ified. Opening and resaving using nano from the CLI fixed it and now it uploads.

I am doing all this stuff via VMWare to an ubuntu 64bit image. It is really good.