reportsheet with comments. commenting not working

Asked by Susanne on 2016-02-05

Hi. I'm sorry for asking som many questions, but i really think schooltool is great, and it is just what we need. I just set up and deployed a spreadsheet for the year, and tried to add a comment as a scoresystem. It all works fine, untill I'm going to write the comment. The box i'm supposed to write in, are popping up, but i cant write in it.. i don't get any error codes, so I have no idea what is wrong. I can write comments if i click on the student and then "score", but i'm afraid that this will cause unnecessary confusion among the teachers (aka more work for me)... It's not the biggest thig, but it would be a nice feature if it worked :)

Question information

Language:
English Edit question
Status:
Solved
For:
SchoolTool Edit question
Assignee:
No assignee Edit question
Solved by:
Douglas Cerna
Solved:
2016-03-15
Last query:
2016-03-15
Last reply:
2016-02-05
Tom Hoffman (tom-hoffman) said : #1

Are you using SchoolTool 2.8?

Susanne (seb1987) said : #2

 SchoolTool versions
schooltool 2.8.3
schooltool.cando 2.8.2
schooltool.gradebook 2.8.3.1
schooltool.intervention 2.7.0
schooltool.lyceum.journal 2.8.2.1

Tom Hoffman (tom-hoffman) said : #3

What browser are you using?

Best Douglas Cerna (replaceafill) said : #4

Hi Susanne.

Try upgrading to schooltool.gradebook 2.8.4 (http://book.schooltool.org/2.8-release-notes.html#schooltool-gradebook-2-8-4). That issue should have been fixed there.

Susanne (seb1987) said : #5

thanx, i will try that. I have installed schooltool inside docker, so I just have to figure out how to update it. :)

Susanne (seb1987) said : #6

Thanks Douglas Cerna, that solved my question.

Jan (ph-ubuntu) said : #7

Upgrading to gradebook 2.4.1 did not solve the issue for me. Is the bug reintroduced in 2.4.1?

schooltool 2.8.5
schooltool.cando 2.8.2
schooltool.gradebook 2.8.4.1
schooltool.intervention 2.7.1
schooltool.lyceum.journal 2.8.2.1

Tom Hoffman (tom-hoffman) said : #8

OK, so it has never worked for you?

Jan (ph-ubuntu) said : #9

I am just setting up schooltool. Before upgrading from 2.6 to 2.8 (and thus gradebook 2.8.4) it did not work either.

I experience this in both Firefox and Google Chrome. Is there any data I can provide you with? Browser console window?

Jan (ph-ubuntu) said : #10

And to add to my previous post: I am also unable to enter comments through the student -> score menu; something that was possible for OP.

Firefox churns out this error in the inspect->console menu:

Gebruik van getPreventDefault() wordt niet meer ondersteund. Gebruik in plaats daarvan defaultPrevented. jquery.min.js:3527:28
Gebruik van getAttributeNode() wordt niet meer ondersteund. Gebruik in plaats daarvan getAttribute(). jquery.min.js:2692:24

(loosly translated: "Usage of .. is no longer supported. Use .. instead.

Tom Hoffman (tom-hoffman) said : #11

Can you check the output of:

apt-cache policy libjs-jquery

Should look like:

hoffman@stone:~$ apt-cache policy libjs-jquery
libjs-jquery:
  Installed: 1.7.2+dfsg-2ubuntu1
  Candidate: 1.7.2+dfsg-2ubuntu1
  Version table:
 *** 1.7.2+dfsg-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
        100 /var/lib/dpkg/status

Jan (ph-ubuntu) said : #12

redacted@redacted:~$ apt-cache policy libjs-jquery
libjs-jquery:
  Installed: 1.7.2+dfsg-3ubuntu2
  Candidate: 1.7.2+dfsg-3ubuntu2
  Version table:
 *** 1.7.2+dfsg-3ubuntu2 0
        500 http://ports.ubuntu.com/ wily/main armhf Packages
        500 http://ports.ubuntu.com/ubuntu-ports/ wily/main armhf Packages
        100 /var/lib/dpkg/status

I am running it on Ubuntu 15.10 (MATE) for Raspberry Pi.

Tom Hoffman (tom-hoffman) said : #13

Ah. We only support 14.04.

Jan (ph-ubuntu) said : #14

I understand. I will keep trying and post a solution if I find one. Thanks for the support anyhow!