reports taking days loading in backgroud without any success

Asked by jerome jones on 2014-07-20

i am trying to generate a detail report for my students only 5 for testing and its two days now and im not seeing a report downloaded. help

Question information

Language:
English Edit question
Status:
Solved
For:
SchoolTool Edit question
Assignee:
No assignee Edit question
Solved by:
jerome jones
Solved:
2014-08-19
Last query:
2014-08-19
Last reply:
2014-08-10
Tom Hoffman (tom-hoffman) said : #1

If you click on Home (as manager) you should see some kind of notification (ideally a link to the report) under Messages. Otherwise see: http://book.schooltool.org/troubleshooting.html

jerome jones (blessedchild44) said : #2

all services are running i see the messages but they are not links

see file attached

On Sun, Jul 20, 2014 at 12:11 PM, Tom Hoffman <
<email address hidden>> wrote:

> Your question #251914 on SchoolTool changed:
> https://answers.launchpad.net/schooltool/+question/251914
>
> Status: Open => Needs information
>
> Tom Hoffman requested more information:
> If you click on Home (as manager) you should see some kind of
> notification (ideally a link to the report) under Messages. Otherwise
> see: http://book.schooltool.org/troubleshooting.html
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/schooltool/+question/251914
>
> You received this question notification because you asked the question.
>

Tom Hoffman (tom-hoffman) said : #3

OK, I've got the log in your email, we'll have a look at the error later today.

Douglas Cerna (replaceafill) said : #4

It's an import problem:

  File "/usr/lib/python2.7/dist-packages/schooltool/lyceum/journal/browser/journal.py", line 2653, in requirement
    dt = dateutil.parser.parse(dts)
AttributeError: 'module' object has no attribute 'parser'

It's fixed in trunk (see line 27) http://bazaar.launchpad.net/~schooltool-owners/schooltool.lyceum.journal/trunk/revision/465/src/schooltool/lyceum/journal/browser/journal.py

Douglas Cerna (replaceafill) said : #5

Looking closer at the code, this should only affect cell validation, not reports as far as I can tell. Could you please attach /var/log/schooltool/celery_report.log?

jerome jones (blessedchild44) said : #6

i tried to run the owner 2.8 and now im not seeing the schooltool
page....oh jesus

On Mon, Jul 21, 2014 at 5:46 AM, Douglas Cerna <
<email address hidden>> wrote:

> Your question #251914 on SchoolTool changed:
> https://answers.launchpad.net/schooltool/+question/251914
>
> Douglas Cerna posted a new comment:
> It's an import problem:
>
> File
> "/usr/lib/python2.7/dist-packages/schooltool/lyceum/journal/browser/journal.py",
> line 2653, in requirement
> dt = dateutil.parser.parse(dts)
> AttributeError: 'module' object has no attribute 'parser'
>
> It's fixed in trunk (see line 27) http://bazaar.launchpad.net
> /~schooltool-
>
> owners/schooltool.lyceum.journal/trunk/revision/465/src/schooltool/lyceum/journal/browser/journal.py
>
> --
> You received this question notification because you asked the question.
>

jerome jones (blessedchild44) said : #7

Thanks Much

On Mon, Jul 21, 2014 at 4:08 AM, Tom Hoffman <
<email address hidden>> wrote:

> Your question #251914 on SchoolTool changed:
> https://answers.launchpad.net/schooltool/+question/251914
>
> Tom Hoffman posted a new comment:
> OK, I've got the log in your email, we'll have a look at the error later
> today.
>
> --
> You received this question notification because you asked the question.
>

Tom Hoffman (tom-hoffman) said : #8

What's your status, Jerome?

jerome jones (blessedchild44) said : #9

Tom Big Problem i try to run the app repository for app owners 2.8 and now
i cant see school tool popping in my browser

On Mon, Jul 21, 2014 at 4:08 AM, Tom Hoffman <
<email address hidden>> wrote:

> Your question #251914 on SchoolTool changed:
> https://answers.launchpad.net/schooltool/+question/251914
>
> Tom Hoffman posted a new comment:
> OK, I've got the log in your email, we'll have a look at the error later
> today.
>
> --
> You received this question notification because you asked the question.
>

Tom Hoffman (tom-hoffman) said : #10

OK, so can you go back to the troubleshooting process and give us the output of

$ sudo service schooltool status

and also the contents of /var/log/schooltool/celery_report.log

Do you have any real data in this instance or are you just experimenting?

jerome jones (blessedchild44) said : #11

nothing is in the celerity.log

On Mon, Jul 21, 2014 at 3:07 PM, Tom Hoffman <
<email address hidden>> wrote:

> Your question #251914 on SchoolTool changed:
> https://answers.launchpad.net/schooltool/+question/251914
>
> Status: Open => Needs information
>
> Tom Hoffman requested more information:
> OK, so can you go back to the troubleshooting process and give us the
> output of
>
> $ sudo service schooltool status
>
> and also the contents of /var/log/schooltool/celery_report.log
>
> Do you have any real data in this instance or are you just
> experimenting?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/schooltool/+question/251914
>
> You received this question notification because you asked the question.
>

jerome jones (blessedchild44) said : #12

and i cant open schooltool in my browser. It is my duty to understand
schooltool and to install it at 3 propose schools in Jamaica so im
expermenting. Plz help me bring it up back it started when i tried to
update from owners app repo 2.6 to 2.8

On Tue, Jul 22, 2014 at 12:29 AM, Day Del <email address hidden> wrote:

> nothing is in the celerity.log
>
>
> On Mon, Jul 21, 2014 at 3:07 PM, Tom Hoffman <
> <email address hidden>> wrote:
>
>> Your question #251914 on SchoolTool changed:
>> https://answers.launchpad.net/schooltool/+question/251914
>>
>> Status: Open => Needs information
>>
>> Tom Hoffman requested more information:
>> OK, so can you go back to the troubleshooting process and give us the
>> output of
>>
>> $ sudo service schooltool status
>>
>> and also the contents of /var/log/schooltool/celery_report.log
>>
>> Do you have any real data in this instance or are you just
>> experimenting?
>>
>> --
>> To answer this request for more information, you can either reply to
>> this email or enter your reply at the following page:
>> https://answers.launchpad.net/schooltool/+question/251914
>>
>> You received this question notification because you asked the question.
>>
>
>

Tom Hoffman (tom-hoffman) said : #13

OK, can you do

$ sudo service schooltool status

again and send us the error log again?

Is this on a clean install of Ubuntu, using apt-get to install the packages? Which version of Ubuntu?

jerome jones (blessedchild44) said : #14

Ubuntu Server 14... using VMW and the status shows schooltool starting and
again started with its uptime and yes i used the atp-get to install package

On Tue, Jul 22, 2014 at 2:47 AM, Tom Hoffman <
<email address hidden>> wrote:

> Your question #251914 on SchoolTool changed:
> https://answers.launchpad.net/schooltool/+question/251914
>
> Status: Open => Needs information
>
> Tom Hoffman requested more information:
> OK, can you do
>
> $ sudo service schooltool status
>
> again and send us the error log again?
>
> Is this on a clean install of Ubuntu, using apt-get to install the
> packages? Which version of Ubuntu?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/schooltool/+question/251914
>
> You received this question notification because you asked the question.
>

Tom Hoffman (tom-hoffman) said : #15

Could you send us the error log again, please?

Tom Hoffman (tom-hoffman) said : #16

Probably the more important point is that just wiping and starting over will save a lot of time and confusion.

jerome jones (blessedchild44) said : #17

THANK YOU SIR TOM. I REALLY APPRECIATE THE HELP.

On Mon, Jul 28, 2014 at 6:41 AM, Tom Hoffman <
<email address hidden>> wrote:

> Your question #251914 on SchoolTool changed:
> https://answers.launchpad.net/schooltool/+question/251914
>
> Tom Hoffman posted a new comment:
> Probably the more important point is that just wiping and starting over
> will save a lot of time and confusion.
>
> --
> You received this question notification because you asked the question.
>

Tom Hoffman (tom-hoffman) said : #18

Is it working now?

jerome jones (blessedchild44) said : #19

report still not loading i only saw the message on the home tab but no link
to see the report and i really want to launch it at a school forr the
coming year sept 2014.

is the browser a likely problem?
firefox

On Mon, Aug 4, 2014 at 2:32 AM, Tom Hoffman <
<email address hidden>> wrote:

> Your question #251914 on SchoolTool changed:
> https://answers.launchpad.net/schooltool/+question/251914
>
> Status: Open => Needs information
>
> Tom Hoffman requested more information:
> Is it working now?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/schooltool/+question/251914
>
> You received this question notification because you asked the question.
>

Tom Hoffman (tom-hoffman) said : #20

It is not the browser. You can send us the error log or just reinstall.

jerome jones (blessedchild44) said : #21

Ive never seen a report generated and where is the error log
On Aug 5, 2014 3:32 AM, "Tom Hoffman" <email address hidden>
wrote:

> Your question #251914 on SchoolTool changed:
> https://answers.launchpad.net/schooltool/+question/251914
>
> Status: Open => Needs information
>
> Tom Hoffman requested more information:
> It is not the browser. You can send us the error log or just reinstall.
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/schooltool/+question/251914
>
> You received this question notification because you asked the question.
>

Tom Hoffman (tom-hoffman) said : #22

Well, you sent it to us before at https://bugs.launchpad.net/schooltool/+bug/1345756

jerome jones (blessedchild44) said : #23

Im only seeing report loading and the dialog showing
Sheduled.
You can close this dialog and download the exported data later from your home
page <http://127.0.0.1:7080/persons/manager>.

and it will stay there loading for the whole day without any success

On Wed, Aug 6, 2014 at 12:26 PM, Tom Hoffman <
<email address hidden>> wrote:

> Your question #251914 on SchoolTool changed:
> https://answers.launchpad.net/schooltool/+question/251914
>
> Status: Open => Needs information
>
> Tom Hoffman requested more information:
> Well, you sent it to us before at
> https://bugs.launchpad.net/schooltool/+bug/1345756
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/schooltool/+question/251914
>
> You received this question notification because you asked the question.
>

jerome jones (blessedchild44) said : #24

error log.

2014-08-03 20:44:46,189 http://localhost:7080/favicon.ico
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/zope/publisher/publish.py",$
    obj = request.traverse(obj)
  File "/usr/lib/python2.7/dist-packages/zope/publisher/browser.py",$
    ob = super(BrowserRequest, self).traverse(obj)
  File "/usr/lib/python2.7/dist-packages/zope/publisher/http.py", li$
    ob = super(HTTPRequest, self).traverse(obj)
  File "/usr/lib/python2.7/dist-packages/zope/publisher/base.py", li$
    obj = publication.traverseName(self, obj, entry_name)
  File "/usr/lib/python2.7/dist-packages/zope/app/publication/zopepu$
    ob2 = adapter.publishTraverse(request, nm)
  File "/usr/lib/python2.7/dist-packages/schooltool/traverser/traver$
    raise NotFound(self.context, name, request)
NotFound: Object: <schooltool.app.app.SchoolToolApplication object a$
2014-08-03 20:54:47,383 http://localhost:7080/favicon.ico

On Sun, Jul 20, 2014 at 1:26 PM, jerome jones <
<email address hidden>> wrote:

> New question #251914 on SchoolTool:
> https://answers.launchpad.net/schooltool/+question/251914
>
> i am trying to generate a detail report for my students only 5 for testing
> and its two days now and im not seeing a report downloaded. help
>
> --
> You received this question notification because you asked the question.
>

Tom Hoffman (tom-hoffman) said : #25

OK, thanks Jerome. We'll try to get a look at this.

I would emphasize that if you are using this instance for testing and there is nothing else important on the server, the quickest way for you to have a working SchoolTool would simply be to reinstall Ubuntu and SchoolTool.

Douglas Cerna (replaceafill) said : #26

The NotFound favicon.ico problem (which we should fix btw) should not affect report generation. Could you please paste the contents of /var/log/schooltool/celery_report.log?

jerome jones (blessedchild44) said : #27

i have launched schooltool at a school and i'm having the same issue so i
am trying to correct it

On Sun, Aug 10, 2014 at 2:52 AM, Tom Hoffman <
<email address hidden>> wrote:

> Your question #251914 on SchoolTool changed:
> https://answers.launchpad.net/schooltool/+question/251914
>
> Tom Hoffman posted a new comment:
> OK, thanks Jerome. We'll try to get a look at this.
>
> I would emphasize that if you are using this instance for testing and
> there is nothing else important on the server, the quickest way for you
> to have a working SchoolTool would simply be to reinstall Ubuntu and
> SchoolTool.
>
> --
> You received this question notification because you asked the question.
>

jerome jones (blessedchild44) said : #28

I installed the PPA:owners/2.8 and it sloves all