Clean Install of 2.8 on Ubuntu 14.04

Asked by Stephen Porter on 2014-05-19

I am running Ubuntu Server 14.04. I have run the following commands and modification on a clean install in hopes of testing 2.8 on a Proof of Concept server.

"sudo add-apt-repository ppa:schooltool-owners/2.8"
"sudo apt-get install schooltool"
Modification of "paste.ini" for external web access. (

Installation process looks to complete without errors, but once I open a browser, the SchoolTool Version is still listed as 2.6.3. On the .../7080/settings page I'm getting schooltool 2.6.3, schooltoolcando 2.6.2, schooltool.gradebook 2.6.3, schooltool.intervention 2.6.2, schooltool.lyceum.journal 2.6.3.

I am guessing that my system is not pointing to the 2.8 repository yet. Can you point me (and my system) in the right direction. Thanks.

Stephen Porter
Pagosa Valor Academy

Question information

English Edit question
SchoolTool Edit question
No assignee Edit question
Solved by:
Douglas Cerna
Last query:
Last reply:
Best Douglas Cerna (replaceafill) said : #1

I think you installed from the universe repository instead of the PPA. You need to run "sudo apt-get update" after adding the PPA:

"sudo add-apt-repository ppa:schooltool-owners/2.8"
"sudo apt-get update"
"sudo apt-get install schooltool"

If you don't want to start from scratch again you can upgrade the 2.6 version by doing:

"sudo apt-get update"
"sudo apt-get upgrade"

I hope this helps.

Tom Hoffman (tom-hoffman) said : #2

I'll make the docs more clear.

Thank you, that worked great!

Mr. Cerna and Mr. Hoffman... Thank you for the support you give the community and education!

Thanks Douglas Cerna, that solved my question.