installation of schooltool 2.6 fails to complete

Asked by athar

i have been trying to install 2.6 on my ubuntu 12.04 (which is a zentyal server). i previously had it working but for some reason it stopped working and then i removed it using the apt-get autoremove schooltool command , and now when i am trying to install the installtion stops halfway through and. I will write the last few lines that are on the screen:

Starting supervisor: /usr/lib/python2.7/dist-packages/supervisor/options.py:293: UserWarning Supervisord is running as root and it is searching for its configuration file in default locations (including its current working directory); you probably want to specify a "-c" argument specifying an absolute path to a configuration file for iproved security.
  'Supervisord is running as root and it is searching '
supervisord.
Setting up school (1:2.6.0.1-0ubuntu1) ...
Processing triggers for python-support ...

After this i am returned to the main command propmt and the installation does not continue. I have tried installing as root user also but this has not made a difference, I am using the dev repository
thank you so much if someone could help

Question information

Language:
English Edit question
Status:
Expired
For:
SchoolTool Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Gediminas Paulauskas (menesis) said :
#1

The error is from supervisor, and looks like you have not upgraded it. The old version (from precise repositories) should work, but it gives this warning.

This may indicate that you have not fully upgraded schooltool. Do

  $ sudo apt-get dist-upgrade

Revision history for this message
athar (athar132) said :
#2

i have tried this, still no luck. schooltool was working on the first ever install, after that i have tried to remove and reinstall several times, but i just cannot get it to work.

to completely remove schooltool from the system, i have used the following commands,

apt-get autoremove schooltool
i have also done apt-get autoremove supervisor

i also tried to install 2.6 by using the command apt-get install schooltool 2.6 (this was a very large file about 500MB), which was the first one i installed and worked, but i have also removed this.

is there any other way i could completely remove it from the system. ? i have even deleted the directories. /var/lib/schooltool, and /etc/schooltool
so that i can do a fresh install

thanks

Revision history for this message
Gediminas Paulauskas (menesis) said :
#3

To remove a package and its configuration files, do

  $ sudo apt-get remove --purge schooltool

I cannot guess what is wrong without more terminal output or error logs. Does it start? What's the output of

  $ sudo service schooltool status

The most likely file where errors are output, is

/var/log/schooltool/paste.log

Revision history for this message
Launchpad Janitor (janitor) said :
#4

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.