SchoolTool not start

Asked by Alisson C O Campelo

After solved my previous problem, the Schooltool not started anymore. So, I decided to reinstall everything again. Before I had installed with tarball. Now:

Installed Ubuntu 10.04 in my server in the cloud.

Add both PPA (ppa:schooltool-owners/dev and ppa:schooltool-owners/ppa)

# apt-get update
#apt-get install schooltool

Great, everything installed. Success. But not started.

In /etc/schooltool/standard/paste.ini , I changed the local address for DNS name in the server cloud.

Restarted or started Schooltool and did not work. (http://servercloud:7080)

Below is the log:

File "/usr/lib/pymodules/python2.6/paste/deploy/", line 431, in _context_from_use
    object_type, name=use, global_conf=global_conf)
  File "/usr/lib/pymodules/python2.6/paste/deploy/", line 361, in get_context
  File "/usr/lib/pymodules/python2.6/paste/deploy/", line 248, in loadcontext
  File "/usr/lib/pymodules/python2.6/paste/deploy/", line 285, in _loadegg
    return loader.get_context(object_type, name, global_conf)
  File "/usr/lib/pymodules/python2.6/paste/deploy/", line 561, in get_context
    object_type, name=name)
  File "/usr/lib/pymodules/python2.6/paste/deploy/", line 581, in find_egg_entry_point
  File "/usr/lib/python2.6/dist-packages/", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/dist-packages/", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: distribute

How to fix this problem?? Can help me?

Question information

English Edit question
SchoolTool Edit question
No assignee Edit question
Solved by:
Gediminas Paulauskas
Last query:
Last reply:
Revision history for this message
Gediminas Paulauskas (menesis) said :

One package is missing. Do

$ sudo apt-get install python-setuptools

Revision history for this message
Alisson C O Campelo (alisson-campelo) said :

New error in error.log:
File "/usr/lib/python2.6/dist-packages/zc/resourcelibrary/", line 115, in _implicitResult
    html = self._generateIncludes(resource_libraries)
  File "/usr/lib/python2.6/dist-packages/zc/resourcelibrary/", line 159, in _generateIncludes
    url = library_resources[file_name]()
  File "/usr/lib/python2.6/dist-packages/zope/browserresource/", line 72, in __getitem__
    raise KeyError(name)
KeyError: u'jquery-ui.min.js'

I searched in the web and not found solution.

Revision history for this message
Best Gediminas Paulauskas (menesis) said :

Workaround this issue by creating a link to the real file:

$ sudo ln -s /usr/share/javascript/jquery-ui/jquery-ui-1.7.2.custom.min.js /usr/share/javascript/jquery-ui/jquery-ui.min.js

I will fix this in the next round of releases (2.0.3)

Revision history for this message
Alisson C O Campelo (alisson-campelo) said :

Thank's very much.
I Choose to install the source package schooltool.gradebook.
The server is already in production.

Revision history for this message
Alisson C O Campelo (alisson-campelo) said :

Thanks Gediminas Paulauskas, that solved my question.