Gradebook is not visible after install

Asked by Alisson C O Campelo on 2012-03-08

Sorry for my english...
After install a SchoolTool 2.0.2 in Ubuntu 10.04 and populating my school (Students, Teachers and creating sections and add instructor), I searched exhaustively for menu gradebook (logged for a teacher) and not found.

My question is: The Gradebook is a separate module?
I`m following The SchoolTool book.

Question information

Language:
English Edit question
Status:
Solved
For:
SchoolTool Edit question
Assignee:
No assignee Edit question
Solved by:
Gediminas Paulauskas
Solved:
2012-03-09
Last query:
2012-03-09
Last reply:
2012-03-09
Best Gediminas Paulauskas (menesis) said : #1

Yes,

$ sudo apt-get install python-schooltool.gradebook

A teacher may need to be an instructor of at least one section to have a gradebook tab, not sure.

Thanks for your reply.
But, still not resolved.
See my terminal:
"
root@xxxcnn5030:/home/alissoncti# apt-get install python-schooltool.gradebook
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  python-schooltool.gradebook: Depends: python-rwproperty but it is not installable
                               Depends: python-schooltool (>= 1:1.9) but it is not going to be installed
                               Depends: python-z3c.form but it is not going to be installed
                               Depends: python-z3c.optionstorage but it is not installable
                               Depends: python-zope.app.form but it is not going to be installed
                               Depends: python-zope.app.generations (>= 3.5) but it is not installable
                               Depends: python-zope.componentvocabulary but it is not installable
                               Depends: python-zope.html but it is not installable
                               Depends: python-zope.viewlet but it is not installable
E: Broken packages
"
Sugestions?

Gediminas Paulauskas (menesis) said : #3

Looks like you are missing some packages, or maybe installed just the schooltool deb.

Please add both PPAs as described in http://book.schooltool.org/install-2_0.html

Thanks Menesis,

I had already added PPA, but not restarted OS. After restart, all dependency are resolved with $ sudo apt-get install python-schooltool.gradebook. :-)

Thanks Gediminas Paulauskas, that solved my question.

Tom Hoffman (tom-hoffman) said : #6

Oh yes, it doesn't seem like you can get the Ubuntu Software Center to automatically update the packages from the new PPA.