Status Notification Missing

Asked by Underberg on 2017-04-11

On my Ubuntu 16.04 Unity the status notification does not appear when sbackup is running.
I found a few possibilities to solve the problem but nothing of them worked for me.

Someone out there with an idea what the problem is?
Thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
sbackup Edit question
Assignee:
No assignee Edit question
Solved by:
Oumar Aziz OUATTARA
Solved:
2017-04-27
Last query:
2017-04-27
Last reply:
2017-04-26

This is due to the bug #1582080 . The problem is that from ubuntu 16.04, the right to see the Desktop Session environment has been restricted. A fix is to committed http://bazaar.launchpad.net/~sbackup-dev/sbackup/0.11/revision/287

You might be able to apply it on your system manually.

Underberg (ubuuse) said : #2

Thanks a lot for your help.
I have replaced my original /usr/share/sbackup/sbackup/util/system.py with the new one I downloaded here.
Unfortunately after restart ubuntu and running sbackup no indicator appeared in the system tray.
Very unfortunate that it does not work. I am out of town two weeks from now. Maybe you get another idea what the problem could be. Thanks again, I appreciate you helped with.

Hi, Can you test with the new version of that file again ?
http://bazaar.launchpad.net/~sbackup-dev/sbackup/0.11/files

Underberg (ubuuse) said : #4

Thanks again!
I replaced my actual /usr/share/sbackup/sbackup/util/system.py with file http://bazaar.launchpad.net/~sbackup-dev/sbackup/0.11/view/head:/src/sbackup/util/system.py.
This time the indicator appeared in the system tray, unbelievable.
What's the difference?

Underberg (ubuuse) said : #5

Thanks Oumar Aziz OUATTARA, that solved my question.

There were 2 issues, but basically, Sbackup was not able to find out if the desktop you were using was Unity, Gnome or something else.