Not possible to launch sbackup

Asked by Lagoda on 2017-03-25

Hi,
I have change place of logfile.
But after close sbackup i have delete my logfile folder.
After it is not psosible to launch sbackup (without re-create folder same as the start).
I send you this because it is write to send this information.

Traceback (most recent call last):
  File "/usr/bin/sbackup-config-gtk", line 45, in <module>
    main(sys.argv)
  File "/usr/share/sbackup/sbackup/ui/configgui.py", line 2077, in main
    window = SBconfigGTK()
  File "/usr/share/sbackup/sbackup/ui/configgui.py", line 90, in __init__
    self.configman = ConfigManager.ConfigManager(self.default_conffile)
  File "/usr/share/sbackup/sbackup/core/ConfigManager.py", line 248, in __init__
    self.__create_logger()
  File "/usr/share/sbackup/sbackup/core/ConfigManager.py", line 674, in __create_logger
    self.getint("log", "level"))
  File "/usr/share/sbackup/sbackup/util/log.py", line 61, in getLogger
    return LogFactory.__createLogger(name, logfile, level)
  File "/usr/share/sbackup/sbackup/util/log.py", line 97, in __createLogger
    os.makedirs(parentdir)
  File "/usr/lib/python2.7/os.py", line 157, in makedirs
    mkdir(name, mode)
OSError: [Errno 13] Permission non accordée: '/var/log/sbackup'

Question information

Language:
English Edit question
Status:
Solved
For:
sbackup Edit question
Assignee:
No assignee Edit question
Solved by:
Lagoda
Solved:
2017-03-25
Last query:
2017-03-25
Last reply:
2017-03-25

This question was originally filed as bug #1675965.

This is due to a misconfiguration of the user.

Hi,

You configured sbackup to write in a log directory in which you don't have the permission to write yourself. The previous log folder was writable to your user '/home/xxxxxxx/.local/share/sbackup/log/sbackup.log' .

To Fix the configuration
------------------------

- Edit the file $HOME/.config/sbackup/sbackup.conf
- Change the log.file parameter back to a folder in which you can write.
- launch SBACKUP configuration gui

What you probably wanted to do
------------------------------

Launch sbackup in admin mode: gksudo sbackup-config-gtk

Then you have access to Scheduling option and have access rights to every directories.

Lagoda (florent-lagoda) said : #3

Hi,
Yes i know what is the problem and how to resolve.

But when this message appears it is write like this : "uncaught exception , please prevents developers"