no memory on target device using ftp

Asked by Peter Reiser on 2017-03-07

When i use ftp as a target sdbackup reports that the target device has 0 zero free mem (but it has enough) and stops. how can this be handled?

2017-03-07 07:56:27,688 - INFO: Summary of backup
2017-03-07 07:56:27,688 - INFO: Number of directories: 26127.
2017-03-07 07:56:27,689 - INFO: Total number of files: 233730.
2017-03-07 07:56:27,689 - INFO: Number of symlinks: 3.
2017-03-07 07:56:27,689 - INFO: Number of files included in snapshot: 75.
2017-03-07 07:56:27,689 - INFO: Number of new files (also included): 75.
2017-03-07 07:56:27,689 - INFO: Number of files skipped in incremental snapshot: 233655.
2017-03-07 07:56:27,689 - INFO: Number of items forced to be excluded: 1.
2017-03-07 07:56:27,689 - INFO: Number of items to be excluded by config: 0.
2017-03-07 07:56:27,689 - INFO: Maximum free size required is '37 MiB 278 KiB 633'.
2017-03-07 07:56:27,690 - INFO: Available disk size is '0 MiB 0 KiB'.
2017-03-07 07:56:27,703 - ERROR: An error occurred during the backup: Not enough free space in the target directory for the planned backup (free: 0 MiB 0 KiB, required: 37 MiB 278 KiB 633).
2017-03-07 07:56:28,093 - INFO: Terminating GIO File Access Manager.
2017-03-07 07:56:28,097 - INFO: Processing of profile failed with error: Not enough free space in the target directory for the planned backup (free: 0 MiB 0 KiB, required: 37 MiB 278 KiB 633).

Question information

Language:
English Edit question
Status:
Answered
For:
sbackup Edit question
Assignee:
No assignee Edit question
Last query:
2017-03-07
Last reply:
2017-03-07

My guess is that the FTP server is configured to not report its available
space. So to prevent disk space issue Sbackup does not continue.

There are 2 possible actions:
- change the FTP configuration.
- workaround : backup locally and create a crontab that RSYNC your backups
to the FTP.
- Fix: create an option in Sbackup to force the backup even if no space is
available.

Peter Reiser (williman9999) said : #2

thx
unfortunately my ftp (synology nas) does not have an option to turn on.
i cant get to work sdbackup with manual smb mount ("max number of password inputs") or nfs mount ("Location is not mountable").
It only works with already mounted dirs of the system.
but i need to access folders via another login as the user backing up, because my backups should not be writable from the user, so they are protected.

Can you help with this problem?

Provide an answer of your own, or ask Peter Reiser for more information if necessary.

To post a message you must log in.